Login screen is in text mode despite configuring runlevel 5

Hi all,

Trying to solve another issue (my desktop didn’t shutdown after updating to OpenSuse 12,1), I decided to switch to runlevel 3 (without KDE). Then I switched to runlevel 5 to use my KDE but now the login screen is in text mode (as in runlevel 3). :frowning:

/etc/inittab has the right configuration:

Caprica:/ # grep initdefault /etc/inittab
id:5:initdefault:

After log in as root, either kdm, gdm or xdm works fine and launch the graphical interface that allow me to log in KDE with another user, so the /etc/x11/xorg.conf has the right configuration.

The start scripts are in place:
Caprica:/ # ll /etc/init.d/xdm
-rwxr-xr-x 1 root root 6781 ene 2 10:54 /etc/init.d/xdm

Caprica:/ # ll /etc/init.d/rc5.d/*xdm
lrwxrwxrwx 1 root root 6 mar 26 2011 /etc/init.d/rc5.d/K01xdm → …/xdm
lrwxrwxrwx 1 root root 6 feb 17 00:09 /etc/init.d/rc5.d/S12xdm → …/xdm

I haven’t found any clue looking into /var/log/messages

The /var/log/xdm.errors shows the following info:

xdm info (pid 3195): Starting
xdm error (pid 3195): XDMCP socket multicast join to ff02::12b failed, errno 19
xdm info (pid 3195): Starting X server on :0

X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux Caprica 3.1.9-1.4-desktop #1 SMP PREEMPT Fri Jan 27 08:55:10 UTC 2012 (efb5ff4) x86_64
Kernel command line: root=/dev/vg_caprica/lv_root resume=/dev/vg_caprica/lv_swap splash=silent quiet vga=0x31a
Build Date: 10 November 2011 03:34:36PM

Current version of pixman: 0.24.0
Before reporting problems, check X.Org Wiki - Home
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Sun Mar 25 01:42:57 2012
(==) Using config file: “/etc/X11/xorg.conf”
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type “ONE_LEVEL” has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
xdm info (pid 3202): sourcing /etc/X11/xdm/Xsetup
xdm info (pid 3202): sourcing /etc/X11/xdm/Xstartup
xdm info (pid 3233): executing session /etc/X11/xdm/Xsession
xdm info (pid 3195): Shutting down
xdm info (pid 3202): sourcing /etc/X11/xdm/Xreset

Trying to start the script manually fails with the following error:

/etc/init.d/rc5.d/S12xdm start
redirecting to systemctl
Failed to issue method call: Unit S12xdm.service failed to load: No such file or directory. See system logs and ‘systemctl status S12xdm.service’ for details.

Any help will be appreciated,

Impisa

So I am no expert at systemd, but is there a chance the default startup has been changed? To make sure the default is graphical, as root it terminal you can run the following command:

systemctl -f enable graphical.target

I can say that any reading about runlevel is kind of BS. If for some reason the graphics driver does not load, your runlevel can still be at 5 with no desktop loaded. I also found you can run startx as root and get to a graphic screen, but no login which can happen if the video driver is loaded too late, as might occur in Tumbleweed with DKMS in charge.

I found some good info on systemd at this link: systemd - ArchWiki

Thank You,

Could your graphics driver have a configuration problem?

What kind of GPU is it, if it’s an nVidia the problem has been posted many times in these forums, my solution was posted here
http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/472361-upgrading-nvidia-driver-includes-useful-info-new-installs.html

Also, if your system drops to non-graphical mode the last dozen or so lines might describe a specific error (which might not be completely accurate but would likely provide a clue).

HTH,
TS

HTH,
TS

On 2012-03-28 03:56, tsu2 wrote:
>
> Could your graphics driver have a configuration problem?

No, his graphical system works - notice he said:

> After log in as root, either kdm, gdm or xdm works fine and launch the
> graphical interface that allow me to log in KDE with another user, so
> the /etc/x11/xorg.conf has the right configuration.

what doesn’t work, I understand, is “init 5”. Yes, what this command prints
would be interesting. If nothing, then the logs. Any log.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Hi jdmcdaniel3,

I followed you recommendation but the command had an issue:

Caprica:/home/impeesa # id
uid=0(root) gid=0(root) grupos=0(root)

Caprica:/home/impeesa # systemctl -f enable graphical.target
Failed to issue method call: File exists

Caprica:/home/impeesa # systemctl -f enable graphical
Failed to issue method call: Invalid argument

Caprica:/home/impeesa #

So I’ve read the link you sent to learn more about systemd: https://wiki.archlinux.org/index.php/Systemd and I’ve found a very similar command:

Caprica:~ # systemctl enable graphical.target
rm ‘/etc/systemd/system/default.target’
ln -s ‘/lib/systemd/system/graphical.target’ ‘/etc/systemd/system/default.target’
Caprica:~ #

Then I’ve rebooted my desktop and I could login using the KDE login page… Yeah! :slight_smile:

MANY THANKS for your help

Impisa

Hey what ever works works. I am just happy you found a solution that got you in. I have no idea why this would have changed on you and we can only hope that the problem stays fixed. Thanks for letting us know of your success.

Thank You,