Login screen has wrong resolution

I’m using a Notebook Lenovo T420s with integrated Intel graphic card, a Nvidia graphic card and that optimus thing. Right after installing openSuse 12.2 I could not log in, because the login box was shown on a second monitor, which unfortunately did not exist.

However, now the login screen (is this »KDM«?) has the wrong resolution. I’d like to have 1600 x 900, but I can not find any file containing the size of this screen.

Nowadays I’m on TW and installed bumblebee, but the bug resisted to vanish. The bug came with v 12.2.

Where the hell is that dammed wrong resolution (about 1200 x 1024) saved and how can I change it !??

Sigh.

Regards,
Alexander

And after login, is the resolution correct? I have a grub2 helper bash script which can be used to setup your Grub and Plymouth resolutions before the login screen is displayed. You can find it here:

GNU Grub2 Command Help/Config Editor - Version: 1.91: https://forums.opensuse.org/blogs/jdmcdaniel3/gnu-grub2-command-listing-helper-help-input-106/

The hardware Framebuffer video modes are all you have until after the kernel and the selected video driver loads. Sometimes it seems, the original low resolution supported before the install of the proprietary video driver is what sticks. Check out the Framebuffer modes, set your bootup modes to the highest supported before login. One of the blog comments shows what to change in the boot configuration screen. Consider that if after openSUSE is running everything looks fine, I would not lose any sleep over the login screen resolution.

Thank You,

The resolution of Plymouth is correct and the resolution of KDE after the login is correct, but not the KDM display. The resolution of KDE can be set in the system settings. Without setting it there to 1600 x 900, it is incorrect as well (ca. 1200 x 1024).

Any idea, where from KDM gets information about the resolution?

I fixed my resolution problems by adding some lines to** /etc/X11/xorg.conf.d/50-monitor.conf**. The contents I added are as follows:


Section "Monitor"
        Identifier   "VGA1"
        Option "Enable" "true"
        Option "PreferredMode" "1152x864"
EndSection

I am not sure if ‘identifier’ has to be the same as your monitor name or if it can be anything. I just used what KDE identified my monitor as (VGA1). Of course you can change the ‘PreferredMode’ to your resolution of choice.

Yessss. Thank you very much. About drawbacks and disadvantages I will report, if any.