Login Screen Error

Dear Support,

I have been using opensuse 12.1 since it’s release and it has made me the happiest man in the world - I have never had a crash whether minor or major. The system just purrs along - a rock solid distribution; coupled with KDE I love using both daily.

This is the first time I have sought help from opensuse support.

My opensuse 12.1 login screen is garbled/unreadable and barely visible on my laptop screen (15" wide) but on my larger second monitor (23" screen) it is perfect. How do attach a screenshot to this thread? The login box is placed on the right-hand side of the image barely visible. The text is unreadble. The grub mode I am using is (I think) vga=0323. I suspect I am using the wrong vga mode.

Please advise.

System
OpenSUSE 12.1 AMD 64 bit
Asus laptop

Hello trigger3013,

I do not know why you have started two threads within 8 minutes about the same problem. I have closed the other one.

Also, you addressing the people here as “Dear Support” might point to you misunderstanding who we are. We are openSUSE users, just as you. The openSUSE users here on the forums try to help as volunteers their fellow openSUSE users. But they are no “official” support.

On 06/15/2012 12:36 PM, trigger2013 wrote:
> but on my larger second monitor (23"
> screen) it is perfect.

so when you have both screens in use, use the perfect one to log in!

and, afterwards, are both screens usable??

and, if you only use the laptop screen (23 disconnected prior to boot)
is the laptop’s log in screen usable then??

i think there is probably a solution but maybe you have one of those new
machines with two different (switchable) graphics sets built in–a
newfangled thing i don’t yet have a good grip on…and i wouldn’t touch
trying to ‘fix’ it if you are able to log in and use the machine
either with or without the additional screen…


dd

On 2012-06-15 12:36, trigger2013 wrote:

> This is the first time I have sought help from opensuse support.

We are just users helping other users, not support. You only get support if
you buy the box.

> My opensuse 12.1 login screen is garbled/unreadable and barely visible
> on my laptop screen (15" wide) but on my larger second monitor (23"
> screen) it is perfect. How do attach a screenshot to this thread?

We use susepaste.org

> The
> login box is placed on the right-hand side of the image barely
> visible. The text is unreadble. The grub mode I am using is (I think)
> vga=0323. I suspect I am using the wrong vga mode.

What video hardware?


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Firstly, I apologise for addressing the forum members as ‘Dear Support.’ To register to this forum one is transferred to Novell’s SUSE Enterprise website where I spent some time reading about Novell’s commercial support.

My video hardware is ATI radeon HD4570 (512MB), cpu (AMD Athlon-X2), laptop screen dimensions: 16" widescreen.

Here is a screenshot of my laptop’s login screen SUSE Paste

I occasionally use the laptop outside of the house so it’s necessary I fix this problem as I can’t carry the 23" screen around (lol).

Before booting if I disconnect the 23" monitor the laptop incorrectly shows the login screen. After loggin in (whether via laptop or external monitor) both screens work perfectly .

After looking at the screenshot, it may be that an experienced user may know the solution. I look forward to your suggestions to fix this. Thank you very much.

On 2012-06-16 02:16, trigger2013 wrote:
> Here is a screenshot of my laptop’s login screen ‘SUSE Paste’
> (http://susepaste.org/30666462)

Do you have both displays connected when this happens?


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Before booting if I disconnect the 23" monitor the laptop incorrectly shows the login screen. After loggin in (whether via laptop or external monitor) both screens work perfectly .

This is due to the X-server setting the laptop display resolution when the external monitor is attached. Its almost certainly a driver issue. It would be helpful to know more details about your graphics hardware and driver in use. (You haven’t mentioned whether you’re using the proprietary AMD/ATI driver, or as I suspect, the default radeon driver).

Open a terminal and execute this command

/sbin/lspci -nnk

Look for the entry pertaining to your graphics. Alternatively, this will provide useful info too

/usr/sbin/hwinfo --gfxcard

With the dual screen configuration (from boot), if you can log in successfully (using the monitor display), then post the output of

xrandr

then compare/post the xrandr output when only the laptop display is active (from boot).

On 06/16/2012 03:03 AM, Carlos E. R. wrote:
> Do you have both displays connected when this happens?

he answered that in the previous post, with “Before booting if I
disconnect the 23” monitor the laptop incorrectly shows the login screen."

which i find VERY strange…


dd

Thank you, here is the info you requested:

I am using the fglrx driver:

root@desktop:/home/desktop #/usr/sbin/hwinfo --gfxcard
28: PCI 100.0: 0300 VGA compatible controller (VGA)
[Created at pci.319]
Unique ID: VCu0.HDJpnacs6Z7
Parent ID: _Znp.X7KtDpnfKH7
SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: “ATI M92 [Mobility Radeon HD 4500 Series]”
Vendor: pci 0x1002 “ATI Technologies Inc”
Device: pci 0x9553 “M92 [Mobility Radeon HD 4500 Series]”
SubVendor: pci 0x1043 “ASUSTeK Computer Inc.”
SubDevice: pci 0x1b42
Driver: “fglrx_pci”
Driver Modules: “fglrx”
Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
I/O Ports: 0xd000-0xdfff (rw)
Memory Range: 0xfbdf0000-0xfbdfffff (rw,non-prefetchable)
Memory Range: 0xfbdc0000-0xfbddffff (ro,non-prefetchable,disabled)
IRQ: 44 (7615 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00001002d00009553sv00001043sd00001B42bc03sc00i00”
Driver Info #0:
Driver Status: radeon is not active
Driver Activation Cmd: “modprobe radeon”
Driver Info #1:
Driver Status: fglrx is active
Driver Activation Cmd: “modprobe fglrx”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #9 (PCI bridge)

Primary display adapter: #28

===============================================================================

just the laptop:

root@desktop:/home/desktop #xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 1920 x 1920
LVDS connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
1366x768 60.0*+
1280x768 60.0 +
1280x720 60.0 +
1024x768 60.0 +
1024x600 60.0 +
800x600 60.0 +
800x480 60.0 +
640x480 60.0 +
CRT1 disconnected (normal left inverted right x axis y axis)

===============================================================================

and both monitors connected:

root@desktop:/home/desktop #xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 1920 x 1920
LVDS connected (normal left inverted right x axis y axis)
1366x768 60.0 +
1280x768 60.0 +
1280x720 60.0 +
1024x768 60.0 +
1024x600 60.0 +
800x600 60.0 +
800x480 60.0 +
640x480 60.0 +

CRT1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
1920x1080 60.0*+
1680x1050 60.0
1400x1050 60.0
1280x1024 75.0 60.0
1440x900 59.9
1280x960 60.0
1366x768 59.9
1280x800 75.0 60.0
1152x864 75.0 60.0
1280x768 59.9
1280x720 60.0
1024x768 75.0 70.1 60.0
1024x600 60.0
800x600 72.2 75.0 70.0 60.3 56.2
800x480 60.0
640x480 75.0 72.8 60.0

Thank you.

Please, please, please, like deano_ferrari use CODE tags when posting computer text: http://forums.opensuse.org/english/information-new-users/advanced-how-faq-read-only/451526-posting-code-tags-guide.html

> root@desktop:/home/desktop #/usr/sbin/hwinfo --gfxcard
> root@desktop:/home/desktop #xrandr
> root@desktop:/home/desktop #xrandr

because none of those needed to be run as root, i wonder why you did?

you are not logging into KDE as root, are you?


dd

No, I don’t log into KDE as root, but I switched to root because I thought the gfxcard command required root permissions.