login screen coming up again and again (maybe lightdm?) after a recent daily update

Hi
After a recent Tumbleweed (almost daily) update, the login screen shows up again and again even after the correct login password
I think I have been using lightdm. But I am not sure.
The root login is also in trouble as well as my own user login.

Which one is the culprit? The kernel or lightdm or xorg?

I tried Ctrl-Alt-F1 for a command-line login. But when I switched to sddm by switching inside
“/etc/sysconfig Editor”, the login process did not go as far as the login window.

Which display-manger is the most basic and the most trouble-free?

Thanks a lot.

PS: I had a similar trouble about a year ago. That time, I gave up and fresh-installed the LEAP.

Your explanation is not completely clear.

What I think you are saying: you login, and shortly after that the login screen reappears.

If that’s not right, then please explain what is happening.

You are assuming that the problem might be “lightdm”, or might be “xorg”. But it also might be that your desktop environment is crashing shortly after login. And you have not told us what desktop you are using. I’m guessing that it is either KDE Plasma (because you mentioned “sddm”) or XFCE (because you mentioned “lightdm”). But my guess could be wrong. It is always helpful to give the desktop information.

And please provide the output from

zypper lr -d

Put the output in code tags. You can generate the code tags by clicking the ‘#’ icon near the top of the edit window.

But when I switched to sddm by switching inside
“/etc/sysconfig Editor”, the login process did not go as far as the login window.

I’m not sure what you are saying there. You can no longer use the “/etc/sysconfig” editor to change the displaymanager. Instead, you need to run (as root)

update-alternatives --config default-displaymanager

Also the video and any drivers installed

This is a too familiar problem, but I’m really vexed to remember any cause other than /home related, either because /home is mounted ro, or something went wrong with user permissions. Can you use root to create a new user for testing, and successfully login with the new user? If your failure is in using Plasma, can using IceWM instead get you logged in?

As to reliability, I still use only KDM, KDM3 or TDM.

When I ran into that awhile ago (but, in 42.x), I installed KDM and switched to that. Problem disappeared.

On the same machine, in an upgrade to a later version (42.3?), the LightDM problem disappeared and I was able to switch back.

Same problem here, will follow this thread as well. Glad I am not the only one affected :slight_smile:

Maybe you can then provide the information that is missing in the first post (as asked for by nrickert). Because only when you and the OP use the same Desktop, etc. you (and we) can be sure it is the same problem. Now we are all guessing.

So I give more details: Xfce doesn’t start, having a lightdm login loop, the window managers are working fine.

So I provide more info: Xfce doesn’t start, having a lightdm login loop. Window managers work just fine.

The problem appeared after the 20180723 upgrade. Official repos + packman + libdvdcss used only.

More details in: https://forums.opensuse.org/showthread.php/532318-X-server-fatal-errors

Looking at the old thread that you linked, it seems that you can login to Icewm, but not to XFCE. Please recheck that, if you have not done so.

If that works, then can you create a new user account and login to XFCE as the new user?

I’m just trying to track down what might have gone wrong. I’m thinking that something in your saved XFCE settings might be triggering the problem. Perhaps there was a change in XFCE that is not compatible with your saved settings.

As I said earlier, both IceWM and Openbox start. I did create a new user, there is still a login loop while trying to start Xfce.

Then I wonder what is different between your computer and mine (where XFCE starts).

However, during the Beta testing period for Leap 15.0, I sometimes ran into situations where XFCE would not start. But I could login to Gnome. And after successful login to Gnome, I could then login to XFCE. So there may be a weird bug lurking somewhere. But it is the kind of bug that is hard to track down.

No idea. It just doesn’t start, with DM or without it.

I am good with WMs, good they work. Hope an upgrade comes with some magic :slight_smile:

Did you see my reply and try Xfce with the other Display Managers? As I do not see an answer to my post.

You suggested me that in my thread as well, there is an answer there. I tried with xdm, it didn’t work.

Yeah, just saw that. Going in more than one thread is confusing.

Okay, you might try kdm, but I would have expected some difference in one of the others. I agree, probably not just a LightDM problem, then.

By now, everyone found out that the XFCE gets killed right-after the display-manager starts up.
Based on the recent update history, it is almost certain that the current XFCE is not working properly with the recent update of xorg
xorg-x11-server (1.19.6 -> 1.20.0)

that showed up on July 22 on the update server.
Almost a week has passed with no fixing update yet.
I gave up on XFCE for now. I installed sddm and the cinnamon window manager, and started using cinnamon.
Maybe this time, I may not come back to XFCE.

Thanks a lot, everyone.

Cheers.

Maybe this time, I may not come back to XFCE.

Don’t give up so early. XFCE still the best DE imo :slight_smile:

I usually use i3 and XFCE, great experience with both.

Not so, I am running Xfce on multiple machines, no problems on any one of them, all are kept up to date with updates applied every week.

Based on the recent update history, it is almost certain that the current XFCE is not working properly with the recent update of xorg
xorg-x11-server (1.19.6 -> 1.20.0)

that showed up on July 22 on the update server.
Almost a week has passed with no fixing update yet.
I gave up on XFCE for now. I installed sddm and the cinnamon window manager, and started using cinnamon.
Maybe this time, I may not come back to XFCE.

It cannot really be an Xfce problem. It must be some other problem, since – as I said – it is not happening on my multiple machines running all current versions of openSUSE (42.3, 15.0, and TW).

Also, it seems to be specific to a subset of Users. I can see in the IRC and mail lists that multiple people are using Xfce without having this problem.

My guess is it has to do with some configuration setting these unfortunate people have that is different, or is Hardware specific.

I had a clean TW install again, and the problem is still there. So I guess the issue is not in the configuration. Meanwhile, XFCE works fine on Arch with the latest updates.