Login problem

I have a interesting and strange problem. I am not sure if anyone here has any experience with Kaspersky Anti-Virus for Linux but my problem relates to that product.

I am running 11.2 openSUSE and after installing the latest version of the Kaspersky product in question, I went ahead and restarted the machine. At the logon screen, when clicking my user name to log in, the password box would not display.

I tried clicking on the other option and trying it that way and after putting my name in the username box, the machine just started thinking and thinking and nothing happens.

I also tried logging in through terminal service but it would not recognize my password to be correct.

I really need to log into my username since I have important files on that Linux partition. I tried mounting this partition in Windows since I have a dual boot setup but I can only view the folders of the partition and not the contents.

If anyone can help I would greatly appreciate it, thanks alot.

Hi, welcome here.

I don’t know about anti-virus for linux, have been in the linux world for over 10 years now, never have seen a truely serious threat from this side. Others are going to say this too: it’s not much use, linux is not windows.
IMHO you should uninstall K’s anti-virus. Or see which solutions K provides in their linux forums.

How did you install K ?

To backup your files: Download a livecd, boot from it, mount the partition containing your data, write them to USB-disk.

If you followed defaults during install, /home will be on a separate partition, a reinstall would at least solve the problem with K, your /home should remain untouched.

Thanks for the reply.

Just have a few questions. Does it matter what LiveCD it is? Does it have to be 11.2 or can it be 11.3? Just wanted to clear that up.

Also when booting with a LiveCD, do I go to the LiveCD option or Hard Disk? And if I do the LiveCD option, how would I mount the partition I want to access? If I can get those answered I am sure I can take the rest from there.

Please let me know, thanks alot.

Can anyone please confirm this? I really need to know, thanks.

Any linux live CD can be used for this, if you don’t already have one PartedMagic is a small download that by default loads to RAM leaving the CD/DVD drive free to also backup to.

caf4926 has an intro here http://forums.opensuse.org/new-user-…ml#post2077128 use the “mount devices” icon on the desktop to mount your linux partition.

Thanks alot, I appreciate it. I will give this a try.

That link does not work unfortunately, do you have another that might? Thanks.

I notice that link is wrong,try again Using Parted Magic an Introduction - openSUSE Forums

The above intro uses the failsafe settings, use this if the default does not boot on your machine.

you can get Parted Magic hereDownloads

Thanks alot for your help. I was able to at least back up my files from the linux partition. Next thing is to figure out how I can be able to log back into my linux partition.

If I were you, I’d reinstall, and follow the suggestion to create a separate partition for /home.

I have never tried to install Linux on a partition that already contains a copy of Linux. Is it possible to overwrite another existing installation of Linux and also where does it give the option of creating a separate /home folder during the installation?


OpenSuse creates a separate home by default on a normal install.

At the point that the installer recommends a partition scheme you can select expert mode and define how and where things go. TO over write the install partition be sure it is set to mount as / and that format is selected. If this is the first home partition then it too should be formated and mounted as /home. If you want to preserve a previous home partition you do NOT format the home partition.

Have you tried to log into the machine in runlevel 3, to see whether the antivirus still kicks in?

Perhaps, if it doesn’t, you can uninstall from the command line?

I dont know how to log into the machine in runlevel 3, do you know how I would be able to do that?

Also when I do try to log in in runlevel3, do you know what the command would be to uninstall something from a command line? Thanks.

  1. press 3 at boot screen then boot

  2. log in as root and type yast