login problem after security update

I am new to linux and have been setting up a server / workstation to run some numerical simulations with OpenSuse Leap. As I don’t have a lot of experience, I used the recommended setup on the installation disk (BRFS filesystem for root and plasma 5 desktop) and because it is locked in our server room, I have been using the commercial version of nomachine workstation 5 to remotely connect to it. All was working fine until just before Christmas, I installed the security update and since then, I have been having difficulty with the login / restart / power off settings. The first sign of the problem was when I tried to create a new virtual desktop with nomachine which failed to start. I then tried closing all running sessions and restarting the machine and found that I could not restart / shutdown the machine from the desktop. I have subsequently performed a hard restart and the system rebooted and got as far as the login screen. I can happily scroll through the different accounts but I can’t login to any of them. A message is briefly displayed before it returns to the login screen but it is too fast to read. I have tried using the dropdown to switch to the icewin desktop option that was installed but the same happens. I have seen the same problem when using both the simple matrox video card built in to the motherboard and the geforce card in one of the slots so I don’t think that it is a graphics driver problem. I have also tried to boot in to a snapshot from grub but every one that I have tried fails to boot. Does anyone have any suggestions of things to try to either fix or better diagnose the problem?



If I were to guess,
You’ve run out of free space due to BTRFS snapshots.
Any excessive activity on your root partition which I would guess currently holds your virtual machine volume could grow your snapshots of changes excessively fast.

You can check for available free space on your partitions with the following command

df -h

If this is your problem,

Short term solution:
Remove any unnecessary snapshots.
First, list your current inventory of snapshots

snapper list

Then, delete whatever you don’t think are necessary. You’ll find snapshots will be created based on whenever you run zypper, hourly and daily, and hourlies purged every few days but might not be fast enough because of your activity. You may also want to consider that snapshots roll back to a particular point in time which would affect all your virtual machines as well. You can delete by specifying the numbers of the snapshots you want to remove (see the help and MAN pages for detailed info)

snapper delete* number_or_number_list* 

Long term Solution:
You may want to either disable snapshots or move your virtual machine volume to another partition or disk (often highly recommended anyway).


Hi Tsu,

Thanks for the advice. I don’t think that it is a BTRFS problem as there aren’t that many snapshots on the drive (~100). I’m sorry if I caused some confusion with the mention of nomachine - it is similar to VNC but allows for multiple desktop sessions to be started from the remote client as well as linking to the physical desktop. As such, it is not a virtual machine and will not be generating large amounts of snapshot data. I have seen that a number of other people are mentioning getting stuck in similar loops at the login screen (here and here) . I managed to get to the console and could login and run the command line version of YAST. From here I tried to roll back the snapshots to a point before the security update. Sadly, there appears to have been a kernel update in amongst the other updates and so the system is no longer even able to get to the login screen. I’m now resigned to having to reinstall Leap from the DVD but was wondering if it is possible to just delete the /root partition whilst keeping the /home one. The help on the expert partitioner doesn’t really help so any tips would be good.



The main reason of having a separate home partition is that you do not have to format it and that protects your data. So be sure that home is not formatted and simply mounted as /home

Do you have any advice on how to use the expert partitioner on the install DVD to determine what the different partitions are and then how to delete the old root partition and then create a new one? Do I also need to replace the other system partitions (swap, bootloader etc) or can they be kept? How do I set the system to mount the existing /home partition?



Well only experience and knowledge of how things are set up can say exactly what is on what partition. But you could takse a live DVD/CD/USB and mount each and look at them and see what is there.

When dealing with a drive that has old partitions that you may want to keep or reuse you really need to know how things were created or mount each partition and see. The installer will not tell you contents

So I have just about go the system back up and running. It turns out that the “upgrade” option on the installation DVD actually allows you to repair a broken install. This reverted the root partition to an older but working version without needing to mess about with the partitions. This then got me back to the KDE login loop. After looking at some of the other similar threads, I tried using the nomodeset option on booting. This did allow me to login and so it must have been a mixture of issues that had arisen, one of which was display driver based. I tried following the command line nvidia driver installation instructions and can get back in to the system with the full desktop. In a slightly annoying twist, the nomachine server doesn’t like the nvidia drivers (virtual desktops don’t work) whilst the desktop doesn’t like nouveau. This, however, is a different problem which can hopefully be solved through the nomachine configuration files.

Thanks for the help,


Small comment on your response to my post about BTRFS snapshots…

The point to my post wasn’t the number of snapshots but how large each might be. On an extremely busy machine particularly supporting multiple simultaneous virtual machines the tracked changes could be enormous.

This could only have been verified if you ran the command I gave you to determine your disk usage and free space available.