Login language stuck to English


My system main and only language is set to “French fr_FR”, and since upgrade to 42.3, the login screen shows up in english, login menu too. Never had that problem on this system, set up as 13.1 in 2013 and successively upgraded as new versions are available.

How to fix this ?



Try to set the language in YaST->System->Language.

If that doesn’t help, please tell what displaymanager and/or desktop you are using.

language is already set this way

kdm and kde, as set by the installer.


try to switch to a different language in yast>language, confirm, let yast delete the rpms of your language and install those of the other lang. Then do it again, this time switching back to your preferred language. I had this problem after a network install of tumbleweed.

Well, kdm is not set by the installer… But if you upgraded, it wouldn’t be changed either.

What does /usr/share/kde4/config/kdm/kdmrc contain then?

# Language and locale to use in the greeter, encoded like $LANGUAGE.
# If empty, the settings from the environment are used.
# Default is ""

Can you confirm that kdm really is your display manager?

systemctl status display-manager

What does the $LANGUAGE variable setting look like?


I’m just wondering if ‘Language=’ format should be more like fr_FR for example.

Sorry, we don’t live on the same time zone :wink:

daniel@jina-portable:~> systemctl status display-manager
● display-manager.service - X Display Manager
   Loaded: loaded (/usr/lib/systemd/system/display-manager.service; enabled; vendor preset: enabled)
   Active: active (running) since jeu. 2017-08-10 21:22:28 CEST; 3min 1s ago
  Process: 2586 ExecStart=/usr/lib/X11/display-manager start (code=exited, status=0/SUCCESS)
 Main PID: 2655 (kdm)
    Tasks: 6 (limit: 512)
   CGroup: /system.slice/display-manager.service
           ├─2655 /usr/bin/kdm
           └─2691 /usr/bin/Xorg -br :0 vt7 -nolisten tcp -seat seat0 -auth /var/lib/kdm/AuthFiles/A:0-Wn0pGb
daniel@jina-portable:~>echo $LANGUAGE

As a clue, I noticed that /usr/share/kde4/config/kdm/kdmrc was last modified by the time I did the upgrade on last saturday… Maybe a bug in a script ?

That’s no problem. People post and others reply when they can, wherever they may be located. :slight_smile:

Anyway, thanks for confirming the requested details. I still wonder if ‘Languge=fr’ shouldn’t be more like ‘Language=fr_FR’ but that’s just speculation on my part.

As a clue, I noticed that /usr/share/kde4/config/kdm/kdmrc was last modified by the time I did the upgrade on last saturday… Maybe a bug in a script ?

I’m sure wolfie323 will be be able to assist further here.

I switched to sddm, and everything goes right. I don’t understand : my desktop had no problems, switched to sddm when it had to happen in the continuously process of upgrading from 13.1 to 42.2 then Tumbleweed, my laptop stayed stuck with kdm from 13.1 to 42.3.

I had also noticed on the laptop that I had the params in the kernel command line repeated four times as if every upgrade had added his own set…

Thanks for your help.

Well, the problem here likely was that we don’t ship translations for kdm anymore… (sorry for not thinking about that earlier :wink: )
kdm is dead upstream since two years, and the translations have been removed from kde-l10n (upstream) as well about a year ago.

If you are fine with sddm or any other displaymanager, use that.

If you do prefer kdm, you can install the corresponding kdebase4-workspace-l10n-xxx package from here:

I might re-submit that to the distribution at one point but it needs a lot of cleanup. (and other things are more important currently…)

And yes, the displaymanager is not changed on upgrades, that is on purpose. (but the whole concept will be reworked to not use /etc/sysconfig/displaymanager in the near future anyway AFAIK)