login issues with yast and kmail in kde but not gnome

Ok, this has got me flabbergasted. I recently upgraded to opensuse 11 on both my desktop and laptop, both HP’s. The notebook/laptop is an HP Pavillion dv9927cl.

I upgraded the desktop and added the kde packages because I wanted to check out the new kde 4.1 after hearing how it improved over the 4.0. I like the PIM better than evolution because of a couple of other packages included with it. I also like the look better, but everytime I check out kde, I end up staying with gnome.

The laptop was a clean install. I cannot log into yast or check mail with kmail while logged into kde. Both work when logged into gnome. When I start yast from the menu, I will get the login request, but after giving the root password, it just fades to nothing and the logs aren’t giving any clues. Any ideas?

Long shot. Try each of these in turn

/opt/kde3/bin/kdesu /sbin/yast2
/usr/bin/kdesu /sbin/yast2
/usr/bin/gnomesu /sbin/yast2

I suspect one of the KDE options will work and you’ve got the one that doesn’t. Checking with the gnomesu under KDE is a control.

All three commands responded the same initially in that all three commands popped up a windows asking for root’s password.

The two kdesu commands resulted with the prompt jumping to the next new line in the terminal, but after that nothing else happened other than the logs showing that the regular user logged in as root.

The gnomesu command resulted in the terminal version of yast starting. I have checked the kde packages, but haven’t located one that might be missing.

If I su to root in the terminal and simply type the command yast2, that too will bring up the terminal version of yast.

What I find to be odd, is everything works as it should on my desktop and I added kde there when I upgraded to opensuse 11. I am out of town for a while, so I will not be able to compare laptop packages against my desktop to see if there is something the desktop has that the laptop doesn’t.

Thanks for the help though. Any other suggestions?

I guess I will stick with the better desktop, gnome. It has worked for me for the last 8 years and kde has not worked for that time. I have tried it several times during the last 8 years and there is usually a reason that something will not work in kde and gnome usually works without fail ( except for the occasional small bug with one of the applications). It has generally been good. Beside Kontact is the main thing I like from kde and I can run that from gnome. If someone can help to resolve these issues. I might give kde a try again. Maybe I will post at the kde forums and see if someone there can resolve these issues. Thank you for the suggestion, though, KJ44. I do appreciate it.