Login incorrect

I’m using the 64 bit version of 13.1, and am able to log in from the graphical user interface without difficulty. In 12 I was also able to, and not infrequently did, use console login. Since upgrading, my password has never been accepted.
I’ve been reading the Start-Up Manual Chapter 17.1, and tried the first way with the same result. It doesn’t make any difference if I start logged in to my KDE desktop or first log out, my password is rejected.
By contrast with http://forums.opensuse.org/showthread.php/480007-Typing-password-for-root-login-on-console-often-produces-an-quot-incorrect-login-quot-(i-e-fail)?highlight=Login+incorrect, and ignoring occasions when I suspect a typographical error, my successes and failures have been consistent.
I can’t find a bug report on the subject, so suppose that I am, or my computer is, doing something wrong, but can’t think what it could be, so would welcome any advice.
Peter Davis

Do you mean you use the same username/password combination on the GUI login with success and on the CLI login (after doing Ctrl-Alt-F1) which fails?

Yes, I do. You imply that they can be set independently, which could be my problem, as I’d supposed that both were set at installation.

Actually, I didn’t use [Ctrl]+[Alt]+[F1], either. I used [Ctrl]+[Alt]+[F2].

That should not matter

Yes,. that should not matter, I only want to pinpoint it to a short clear description.

And that one user has only one password. Regardless if you login in the GUI or on the console. That is what you expect. And the same here.

Just a guess.
Do you have some very specific character(s) in your password? Outside the “normal” ASCII range?

Yes wasn’t there a problem with double quotes in a password

In fact I was thinking about non Latin characters, but " that is also something to study.

My current password doesn’t include any punctuation that would stand out in an ordinary page of English, or any double quotes"].

The problem is odd. I say since you can log to a GUI log in and change your password in Yast. It maybe will set things right.

I’ve tried both confirming my password and changing it to something so simple that the system didn’t want to accept it. Unfortunately, neither worked, so I’d welcome any further inspiration.

Riddles >:(

I will try to repeat things, just to try to induce an “Oh, yes …” happening.

  1. Going back to your original post here: nobody AFAIK has the same experience, thus it is indeed you or your system;
  2. you say “my password is rejected”, now that is your conclusion, but not litteraly what happened, we allways ask for copied/pasted computer evidence, but that is of course difficult here, nevertheless we love it when you tell us, by writing down and retyping in a post, what you saw, so we can draw our own conclusions;
  3. remember that rejecting a login can be a wrong password, but it can also be a wrong username, the system does not tell too much details, because it would help crackers.

I realy would appreciate if we could join you on the system and work there :wink:

Can you post (where <theusername> should of course be replaced by the username this is all about):

grep '^<theusername>' /etc/passwd


grep '^<theusername>' /etc/shadow

This last one please as root. **And better replace the second : seperated field in that line with something like ??? when posting here. It is your encrypted password.

On 2014-04-07 10:36, hcvv wrote:

> - you say “my password is rejected”, now that is your conclusion, but
> not litteraly what happened, we allways ask for copied/pasted computer
> evidence, but that is of course difficult here, nevertheless we love
> it when you tell us, by writing down and retyping in a post, what you
> saw, so we can draw our own conclusions;

There might be entries in syslog, so I would start:

su -
dmesg --follow --decode --human

in a terminal on the working GUI, them attempt a login in VT1, and back
to the GUI to see what was printed new in the terminal. Might give a clue.

The first post mentions an “upgrade”. How was that made?

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

I suppose you’re right that it is strictly the combination of username and password that’s being rejected, but I can see my shorter username as I type it, so can more easily correct mistakes. On the comparatively rare occasions when I’ve entered an error, I’ve immediately received the message in the title of my post. Usually, I receive the error message after entering my longer password, so the username has effectively already been accepted, and is why I refer to rejection of the password. What I see is simply

Login incorrect

:x:1000:100:Peter Richard Davis:/home/:/bin/bash


I fear I may be doing something wrong here. After several screens of output, I end up without a prompt.

My outputs before and after appear to me to be identical.

It was actually a clean installation from a Live KDE desktop run from a USB stick.

I suspect PAM but hey just a wild guess since pam is responsible for such authentication and the likes, apparmor went haywire? :slight_smile:

OK, I understand. But as I tried to tell you, there is no message whatsoever when you enter a not existing username. The login will allways prompt for the password and then say

Login incorrect.

This is to give no clue to a hacker that he tried a not existing username.

Sorry, but can you please copy/paste the prompt, the command, the output and the prompt between CODE tags? You get the CODE tags by clicking on the # button in the tool bar of the post editor. And do not change things there, except in the case where you have a readable password or similar (here a encrypted password (and then explain that when you post it). People here will trust copied/pasted output much, much more then any story you tell with it. In fact we are non-believers :wink:

I now have to guess that both entries exist and start with the same username.


I tried your dmesg with a wrong login on logical screen 1. There are no messages, thus this test will not help IMHO.

Create a new user (using YaST > Security and Users > Users and Groups) and check ifthe same is true for that user.

You’re right that this is the way it works after [Ctrl]+[Alt]+[F2], but I was almost sure that I got the error message after entering only the username incorrectly when I tried a console login. I wonder if this could be a clue, and will try when I next boot my computer to enter a wrong username in a console login.

My apologies for forgetting the code tags, but the text was copied and pasted output, not any story that you need disbelieve. I supposed that it wasn’t necessary to explain where I was following your instructions, but the ?s are a direct replacement for what I understood to be my encrypted password. Similarly, it seems to me that my username is information useful to the hackers to whom the system seeks to avoid giving clues, so I replaced it with your wherever it occurred. It is, of course, always the same. If you think it could relate to the problem, I can try, as I see you suggested at 15:47, setting up another user account as a test.

<theusername>@UsrFriendesktop:~$ grep '^<theusername>' /etc/passwd
<theusername>:x:1000:100:Peter Richard Davis:/home/<theusername>:/bin/bash
<theusername>@UsrFriendesktop:~$ sudo grep '^<theusername>' /etc/shadow
root's password:

Perhaps I should add, in the hope of giving more satisfaction, that what was the output of the first <theusername>, and now starts the first output, is in red.

You guessed correctly. (I wonder how it could change.)