Login fails for normal user in 11.3 / KDE4


I can’t log into my normal user account at bootup; it just bounces back to the login screen. However, I can log into the user’s terminal window from the root account. I’ve tried deleting and re-creating the user, but to no avail.

Is there some special file that I could delete before re-creating the user? The one that holds the (corrupted) authentication data, perhaps?

Thanks in advance for your replies!

There can be a number of reasons for this. I don’t suspect corrupted user data, but a system problem instead.

  1. Your “/” partition could be full, due to a flooded /tmp. To find out, do

df -h

and post output here. If so, we’ll help you to clean /tmp, don’t do that manually !!!

  1. A graphics card problem. Did you update to a new kernel ? Reinstall the driver.

  2. A mix of packages from different repos. Please post output of

zypper lr -d

For all this, please state your openSUSE version, desktop used, 32/64bit.

Thanks for your reply! My machine isn’t connected to the Internet yet, so there’s no easy way for me to post the results. Nevertheless, I can answer your questions…

df -h

All partitions are near-empty, including / and /tmp. (By the way, how do you recommend cleaning /tmp? – with bash’s rm command?)

  1. Graphics system works fine for root user, and also for a newly created normal user. Not sure if I changed the kernel or driver recently. Incidentally, all trouble occurred due to a power outage. The machine was on, but not in active use at the time.

zypper lr -d

All packages are either from Packman or the various opensuse.org repos.

For all this, please state your openSUSE version, desktop used, 32/64bit.

It’s 64-bit, 11.3/ KDE4. Do you need more information?

This has happened to me before. Usually the solution has been to create a new user and transfer all documents and profiles from the old one. It’s such a cumbersome solution, so I’d like to find one that’s more refined. My guess is that an authentication file needs to be deleted and then reinstatiated by re-creating the user. Any ideas?

I’d check the last few entries in /var/log/kdm.log, especially for lines beginning with ‘(EE)’.

(By the way, how do you recommend cleaning /tmp? – with bash’s rm command?)

No, that can (and should) be done automatically during the boot process. Open the file /etc/sysconfig/cron as root and edit the following line:


Set “no” to “yes” and the content of /tmp will be removed any time you boot.

Excellent, thanks!!

It seems to point to Xorg. Should I delete all Xorg-related components in the /home/user directory?

What “Xorg-related components” are in your /home at all? Either way, they can hardly cause any trouble (I still wonder why they are there).

I am sure we will find out what’s going on when you post the respective part of /var/log/kdm.log.

I had this same problem after changing my graphicsdriver. kwin was configured with compositing enabled, yet the new graphicsdriver did not support this so immediately dropped me back to the loginscreen.
Solved by editing


Find the heading


and change