Login failed

I just installed 13.1 64bit and was in the process of installing various packages when suddenly I started getting failed login when I entered roots password. It had been working great all afternoon. I had it set up for automatic login and had rebooted the system several times and all was well. Just could not log in as root. Today up on boot it now wants a user login. Very, very strange. Have never encountered anything like this before. Any ideas?

It is not quite clear what you are deescribing. One interpretation could be that you loged in as root. I hope that is not the case, because you should never do that.

Guess I was not to clear. Performed a normal install with one user and specified auto log in. Things worked fine and was in the process of installing additional packages, when I was asked by yast to supply root’s password, login failed. This had worked fine many times earlier. Continued to play with the system and had rebooted several times with no problems. Then (remember I had specified auto log on) it started asking for users password at boot. It’s like the password somehow changed or became corrupted.

The particular password should not matter for Auto-Login.
But it seems you have a general problem with the login system here.

Can you actually login now? (i.e. is only Auto-Login not working?)
How does your login screen look like? Maybe post a picture of the screen, it could be you uninstalled the standard login manager by mistake.

Which additional packages did you install and how? (i.e. did you download them from somewhere, did you install them from the standard repos, or did you add some additional repos and installed them from there?)
What repos do you have?

rpm -qa --last | head -n 20
zypper lr -d

Can you login in text mode, either as root or as user?
I.e. press Ctrl+Alt+F1 and try to login there.