Login Crash

Hello, I had an excellent experience with my last issue on this forum, an I hope so have it as good with this one! I use KDE 3.5.9 and when my computer boots up, it goes through the text portion perfectly fine, but when it tries to load the login (automatic), sometimes it seems to crash and display an unmovable mouse cursor, and a few oddly shaped bits of random color. This is the only really big problem I have had with openSUSE 11.

What is your machine’s graphics device? Do you know which graphics driver you have installed. You can which driver by booting into “init 3” by, at the boot menu screen, typing the numeral 3 in the box below (just a 3; if any text is already there, just type the 3 a space after that). You will be booted to a user login prompt; login as root. Then do:

more /etc/X11/xorg.conf

and scroll down until the “Device” section; the driver name is there. Post that back here along with the device ID.

The weird thing is that it only does it sometimes, sometimes it works, and I never noticed it until I ran Folding @ Home once all night, then rebooted. It only has happened after using Folding @ Home.
I tried a simpler method, I opened KWrite and went to that same document in the same location, I don’t know if it is the same thing… but here it is.

/…/

SaX generated X11 config file

Created on: 2008-08-11T22:22:59-0500.

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)

PLEASE DO NOT EDIT THIS FILE!

Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
EndSection

Section “ServerFlags”
Option “AIGLX” “on”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”
EndSection

Section “Module”
Load “glx”
Load “type1”
Load “extmod”
Load “dbe”
Load “freetype”
Load “dri”
EndSection

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “us”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”
EndSection

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “11”
Option “Device” “/dev/input/mice”
Option “Name” “Microsoft Wireless Optical Mouse? 1.00”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “Monitor”
DisplaySize 305 230
HorizSync 30-70
Identifier “Monitor[0]”
ModelName “E773C”
Option “DPMS”
Option “PreferredMode” “1024x768”
VendorName “DELL”
VertRefresh 50-160
UseModes “Modes[0]”
EndSection

Section “Modes”
Identifier “Modes[0]”
EndSection

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1024x768” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 16
Modes “1024x768” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 24
Modes “1024x768” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 8
Modes “1024x768” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”
EndSection

Section “Device”
BoardName “i845”
BusID “0:2:0”
Driver “intel”
Identifier “Device[0]”
Screen 0
VendorName “Intel”
EndSection

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”
EndSection

Section “DRI”
Group “video”
Mode 0660
EndSection

Section “Extensions”
Option “Composite” “on”
EndSection

May I ask why you’re running Folder@Home? Have you overclocked? If you have Windows also on this machine, I suggest you run F@H there as well. F@H is usually for stress-testing the hardware . . . an OS will crash when the cpu or ram is overtaxed, or when there is not sufficient voltage to those components under load. This kind of stress test can also damage the hardware. Perhaps you can elaborate?

I have completely moved away from Windows. I don’t necessarily know why I am running Folding @ Home, I guess I just wanted to contribute to protiene research. But I will not run it anymore and see if it happens again… I don’t think i damaged the hardware though because it has never crashed once booted, and usually boots normal, it just freaks out everyonce in a while. I have not modified my system in any way.

The behavior you first described sounded like it might be a problem with the graphics driver. However, usually when that is the case, the behavior is consistent. You just can’t get the gui, or it is very flakey all the time. In other words, it usually either works or it doesn’t. And if you see the weirdness again, this is probably a place to look. There have been several users with the “intel” graphics driver that have had problems after an automatic update to the kernel and x server updated that driver. So first of all, if you haven’t done such an update yet, might be good to hold off until this other known problem is sorted out. If you have done the update (or even if not), you can take a look in the /var/log/Xorg.0.log file for driver errors (carefully look at the entire file; it’s long). If you see AIGLX errors, particularly later in the file with errors loading “dri” or “glx”, then you may have the above driver problem. Post that back, there are a couple solutions.

Re Folding@Home: Hopefully, that’s not related to what you’re seeing, and it very well may not be. However - now please don’t shoot me - I should mention that when F@H stresses the machine, the cpu, ram, and northbridge get very hot. Some machines have an automatic shutdown to protect the cpu; others do not. And, there is no such built-in protection for the other components. Eventually, it’s possible for one of those components to be damaged. Especially where the ambient temp is already very high (like in the summer where I live). Usually, the symptom is weird unpredictable behavior. So . . . if you start seeing erratic weirdness, you might install the memtest package from the repository; it will add a stanza to your boot menu. You can boot into memtest and test your ram (the default is to cycle thru all 9 tests; do that overnight). If the ram tests OK but still you’re seeing the weirdness, install Prime for Linux, run it and keep your eye on the machine (if you have a dual core cpu, see the readme file on how to run Prime against both cores). If Prime fails, most likely there has been damage. Probably none of this is applicable, but I share it just in case, fwiw.

I just checked this thread Out of ideas - opensuse 11 crashing / freezing - Page 3 - openSUSE Forums and it reminded me of your problem. If you browse the thread you’ll see the user is trying various versions to try to pin down an erratic behavior. Surprisingly, he seems to be isolating it to KDE 3.5.9. Had you (or he) been using KDE 4.x, Plasma would have been quickly suspected. But 3.5.9 is very solid. So something strange is going on. You might check back on that thread to see if that user pins down the problem. Just a thought.

Just Thought I’d say that I have the same problem-
except that mine happend when I remover hardware (cddrives HDD’s)
AFTER I had turned the computer off

There’s my two bit’s