login by VNC

Hi There,

I have a server at home running an ssh server. I have forwarded the ssh port on my router. Now i thought it would be worth a try getting a vnc server on there (pc doesn’t have a screen or anything connected to it - as I’ve just been using it with a plain console interfaace). Anyways, I used yast to install Xvnc and can start it with “Connection reset by peer”.:


Xvnc :0 -rfbport 5900 -geometry 1024x768 &

successfully but then when i connect with a client to xvnc4viewer MyURL:5900 I initially only get the KDM background from KDE 3.5 (you know the black white dot pattern) until the screensaver starts, once the screensaver starts and i move the mouse the vncviewer immediately exists with


reg@Kubuntu:~$ xvnc4viewer MyURL:5900

VNC Viewer Free Edition 4.1.1 for X - built Apr 16 2008 13:02:40
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.

Tue Mar 24 11:28:27 2009
 CConn:       connected to host mytuxnet.no-ip.biz port 5900
 CConnection: Server supports RFB protocol version 3.7
 CConnection: Using RFB protocol version 3.7
 TXImage:     Using default colormap and visual, TrueColor, depth 24.
 CConn:       Using pixel format depth 6 (8bpp) rgb222
 CConn:       Using ZRLE encoding
 CConn:       Throughput 20714 kbit/s - changing to hextile encoding
 CConn:       Throughput 20714 kbit/s - changing to full colour
 CConn:       Using pixel format depth 24 (32bpp) little-endian rgb888
 CConn:       Using hextile encoding

Tue Mar 24 11:28:28 2009
 CConn:       Throughput 445 kbit/s - changing to ZRLE encoding
 CConn:       Using ZRLE encoding

Tue Mar 24 11:28:39 2009
 main:        read: Connection reset by peer (104)
reg@Kubuntu:~$

When I have the mouse pointer outside the vnc window, the sdcreensaver keeps going nicely and vncviewer isn’t crashing… Any clues what may be going on here?

Thanks,

Ron

PS: vncviewer.exe on Window$ says “Connection closed” and i never even get to see anything… :frowning:

Hi
I would look at using either Nx (nomachine.com) or FreeNx (I prefer
nomachine and their Nx) since your using ssh… and one less port to
open, both are free as well.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel 2.6.27.19-3.2-pae
up 4:20, 1 user, load average: 0.45, 0.26, 0.23
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Okay, well I have tried to install the bnxserver package which is dependent on the client & node package as well - so i’ve installed them all but can you explain this:


server:/home/reg/downloads # nxserver --start
-bash: nxserver: command not found
server:/home/reg/downloads # rpm -Uhv nxserver-3.3.0-14.i386.rpm
Preparing...                ########################################### [100%]
        package nxserver-3.3.0-14 is already installed
server:/home/reg/downloads # nxserver --start
-bash: nxserver: command not found
server:/home/reg/downloads # rpm -q nxserver-3.3.0-14.i386.rpm
package nxserver-3.3.0-14.i386.rpm is not installed
server:/home/reg/downloads #

I’m not seeing what’s going on here - what am I doing wrong? >:(

Hi
Use chkconfig and /etc/init.d/ scripts


chkconfig nxserver
(if it's off then)
chkconfig nxserver on
/etc/init.d/nxserver start

Then install the client on the machine you want to connect from and run
the wizard to setup the session.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel 2.6.27.19-3.2-pae
up 6:23, 1 user, load average: 0.21, 0.12, 0.07
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Hmm, weird when i try to establish a connection it times out and shows an error in a message box that reads: “The NX service is not available or the NX access was disabled on host MyURL”
Hitting the Detail button gives me this:


NX> 203 NXSSH running with pid: 7294
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 67.55.17.66 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 204 Authentication failed.

Why is the user nx? i changed it in the wizzard dialog box…? Weird!
On the server side I get:


server:/home/reg/downloads # chkconfig nxserver
nxserver  on
server:/home/reg/downloads #

/var/log/messages tells me this:


Mar 24 11:12:05 server sshd[4504]: reverse mapping checking getaddrinfo for i216 failed - POSSIBLE BREAKIN ATTEMPT!

Hi
Very strange… on the server side, can you restart nxserver and on the
client side remove your ~/.nx directory and try again. Yes the service
is run by the nxuser, it’s normal :slight_smile:


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel 2.6.27.19-3.2-pae
up 0:21, 1 user, load average: 0.67, 0.32, 0.24
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

This is not working for me… :frowning:
i restarted the server:


server:~ # /etc/init.d/nxserver restart
NX> 123 Service stopped.
NX> 153 Stopping NX server monitor.
NX> 153 NX server monitor already stopped.
NX> 122 Service started.
NX> 999 Bye.
NX> 723 Cannot start NX statistics:
NX> 709 NX statistics are disabled for this server.
NX> 999 Bye.
server:~ # chkconfig nxserver
nxserver  on

removed ~/.nx


reg@Kubuntu:~$ rm -r .nx/

and relaunched nxclient.
The errorr i’m getting now is:“The NX service is not availablee orrr the NX access was disabled on host mytuxnet.no-ip.biz.” - ???
Detailss:


NX> 203 NXSSH running with pid: 13038
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 69.171.155.160 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 204 Authentication failed.

I have no clue wghat’s going on here…also, when the user nx tries to login…i don’t have a user nx on my server system… and i manually entered my username as well as the password in the client’s dialog box…

Hi
On the client, can you look in the ~/.ssh directory known_hosts file,
maybe there is a defunct entry for the server.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel 2.6.27.19-3.2-pae
up 11:04, 2 users, load average: 0.22, 0.23, 0.20
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Nope, looks good to me:


reg@Kubuntu:~/downloads$ more ~/.ssh/known_hosts
|1|4cFkXdnbc6hnPKDP25ngoP4tDPI=|2eWa4odpPZQgBzsmpuaGSamzr/4= ssh-rsa AAAAB3NzaC1
yc2EAAAABIwAAAIEAwB2dtl3sJpb/kFjbvLGnFHFriHUvc70FVc6nriCMft30daP0WP5SXphYJKBt7E9
WymTag0CafPYKOAB9zA/wwIH5rPOUl+pnUtZaGA4RhL3V+XNOB8cM6dNscF2802rlZxeJfGT2iWC5YMv
yd0/TLjXGPqtdBLtP2I+HZjtO2EE=
|1|tUfw7zKcy/BvQXexOpaAiGO7zSE=|KVqu0bNFyYa44Ug8lL0onGdCLVs= ssh-rsa AAAAB3NzaC1
yc2EAAAABIwAAAIEAq5CHjisjZXNs3+Yks2MBudRRs+EzgvtkfaN6TTFDUkiKHYHr9/cj8MyLpVlcFCe
EDLq/x+lvbr7tayW4eDTFYJuiVHW816K0ma3w8escpqXdf4p0daB5sZ0MTsORlMdJSWBQneVUBeoXb8g
kA8GxUcBphOF0gsEi5lfYl10USr8=
|1|GxyVaLL1VzY5WhvH/7qiL6nP7i0=|ElNmSzcuUq4o0+IbBXnpqq8eAeI= ssh-rsa AAAAB3NzaC1
yc2EAAAABIwAAAIEAq5CHjisjZXNs3+Yks2MBudRRs+EzgvtkfaN6TTFDUkiKHYHr9/cj8MyLpVlcFCe
EDLq/x+lvbr7tayW4eDTFYJuiVHW816K0ma3w8escpqXdf4p0daB5sZ0MTsORlMdJSWBQneVUBeoXb8g
kA8GxUcBphOF0gsEi5lfYl10USr8=
|1|X7reOejm2VnsT7ROs19ZQsyov84=|Y1gsyerpkWAeXVrR2DE6R0oDCDo= ssh-rsa AAAAB3NzaC1
yc2EAAAABIwAAAIEAq5CHjisjZXNs3+Yks2MBudRRs+EzgvtkfaN6TTFDUkiKHYHr9/cj8MyLpVlcFCe
EDLq/x+lvbr7tayW4eDTFYJuiVHW816K0ma3w8escpqXdf4p0daB5sZ0MTsORlMdJSWBQneVUBeoXb8g
kA8GxUcBphOF0gsEi5lfYl10USr8=
|1|DRYONqK70ZXH/uamYjq4PLUVACU=|V2OcGejm4CWDwKwrUDoSLUagI4k= ssh-rsa AAAAB3NzaC1
yc2EAAAABIwAAAIEAq5CHjisjZXNs3+Yks2MBudRRs+EzgvtkfaN6TTFDUkiKHYHr9/cj8MyLpVlcFCe
EDLq/x+lvbr7tayW4eDTFYJuiVHW816K0ma3w8escpqXdf4p0daB5sZ0MTsORlMdJSWBQneVUBeoXb8g
kA8GxUcBphOF0gsEi5lfYl10USr8=
reg@Kubuntu:~/downloads$

Just to be sure, I deleted it and retried but I get the same after confirming the fingerprint:


NX> 203 NXSSH running with pid: 6052
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 69.171.155.160 on port: 22
NX> 211 The authenticity of host 'mytuxnet.no-ip.biz (69.171.155.160)' can't be established.
RSA key fingerprint is 63:3c:5f:e8:a7:cd:69:09:f5:9e:f7:9d:24:b9:98:11.
Are you sure you want to continue connecting (yes/no)? 
Warning: Permanently added 'mytuxnet.no-ip.biz,69.171.155.160' (RSA) to the list of known hosts.
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 204 Authentication failed.

Hi
Wonder if something is expecting authorized_keys2 file? What about down
in the /usr/NX/home/nx.ssh looks ok?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel 2.6.27.19-3.2-pae
up 13:54, 2 users, load average: 0.27, 0.26, 0.16
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

[QUOTE=malcolmlewis;1963496]Hi
Wonder if something is expecting authorized_keys2 file? What about down
in the /usr/NX/home/nx.ssh looks ok?


no-port-forwarding,no-agent-forwarding,command="/usr/NX/bin/nxserver --login" s
sh-dss AAAAB3NzaC1kc3MAAACBAJe/0DNBePG9dYLWq7cJ0SqyRf1iiZN/IbzrmBvgPTZnBa5FT/0L
cj39sRYt1paAlhchwUmwwIiSZaON5JnJOZ6jKkjWIuJ9MdTGfdvtY1aLwDMpxUVoGwEaKWOyin02IPW
YSkDQb6cceuG9NfPulS9iuytdx0zIzqvGqfvudtufAAAAFQCwosRXR2QA8OSgFWSO6+kGrRJKiwAAAI
EAjgvVNAYWSrnFD+cghyJbyx60AAjKtxZ0r/Pn9k94Qt2rvQoMnGgt/zU0v/y4hzg+g3JNEmO1PdHh/
wDPVOxlZ6Hb5F4IQnENaAZ9uTZiFGqhBO1c8Wwjiq/MFZy3jZaidarLJvVs8EeT4mZcWxwm7nIVD4lR
U2wQ2lj4aTPcepMAAACANlgcCuA4wrC+3Cic9CFkqiwO/Rn1vk8dvGuEQqFJ6f6LVfPfRTfaQU7TGVL
k2CzY4dasrwxJ1f6FsT8DHTNGnxELPKRuLstGrFY/PR7KeafeFZDf+fJ3mbX5nxrld3wi5titTnX+8s
4IKv29HJguPvOK/SI7cjzA+SqNfD7qEo8=


Doesn’t look too shabby either - does it?
I removed it and tried again but get the same:


NX> 203 NXSSH running with pid: 6604
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 69.171.155.160 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 204 Authentication failed.

Hi
Hmmm, I must admit I’ve never had problems like this :frowning: All I can
suggest is removing the rpms on the server and client and re-install.

Else have a search on the nomachine site?

I’m assuming the client is also from nomachine?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel 2.6.27.19-3.2-pae
up 17:23, 2 users, load average: 0.22, 0.24, 0.25
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME