Logging out --> black screen?

Hi there!

I’m having a weird issue with openSuse 11.0 KDE4 version.

Sometimes, when I logout, I don’t get the cute login screen (kudos for openSuse artists, BTW), but a black screen. Then, nothing works: Ctrl+Alt+(Backslash/F3/F4/F5…) I just hang there and force-power-off my laptop.

I installed the ATI drivers from openSuse repo and got 3D acceleration enabled, but I can’t say if that behaviour is from that moment on or if it happened before. Is this driver related? Is it happening to someone else?

Thanks a bunch,

EDIT: BTW, this also happens when I restart X by Ctrl+Alt+Backslash, but not always.


same problem after installing ATI drivers on my Acer Travelmate 4000. Before installing I could logout and switch to another user.

The same, black screen, also happens if I suspend to RAM and sometimes if I do a suspend to disk (Hibernate). However the latter is not consequent, maybe caused if I suspend to disk for a second time.

for ATI driver OpenSuse.org suggests that “sudo aticonfig --initial” is not necessary for Suse 11, but in my case I had to use this before I could run the program “ATI graphics adapter settings”. And I must say it’s the first time, since v 10.0, that I can install the ATI driver on my Laptop and run 3D.

If I open Configure Kdesktop I get the error “Your X server is using the RandR extension at version 1.2 or greater which doesn’t have any configuration yet”
I’m not that experienced, but it could be that the black screen is a result of conflicts. Apparently the general driver is still active.

I could use some help. Apart from all other improvements, e.g. a smooth upgrade from 10.3 to 11.0 (10.2 → 10.3 was a disaster), a major step forward is that the powersave at last recognizes my smart Battery, so I definitely want to stay with suse


Also have the same problem with GNOME and openSUSE 11.0. Had the same problem when I was using Ubuntu too. Any help would be appreciated.

Same here. I installed OpenSUSE 11.0, updated with the security patches, installed the nvidia-driver. Then tried to log out -> black screen and the system hangs up.

After this I installed OpenSUSE again and tried to log out -> everything was ok, gdm appears.

It must have something to do withe the patches or the videocard driver.

Did anybody solved this problem?

I have the same problem.
My Graphic Card is NVidia Quando NVS 140M

No driver, no problem.

First I thought if I uninstall the driver of the nvidia source (rpm) and install the newest beta(**run) will work.
But still… logging out and “Ctrl+Alt+Backspace” bring out the black screen.

So it happens not only on the nvidia card.
I think it may be a bug of kde4.1.

Same graphic card here; it looks like NVidia driver does something do kdm so after logout kdm cannot start X and goes to timeout. Crtl+alt+del would probably work after 30 or so seconds when you try to logout. At least the system can shut down gracefully.

I uninstalled NVidia drivers and now it works fine, but kind of slow.

and even nobody care about these
Bug #460428
Bug #462356
Bug #461262