Logged In Under X, Can't Get Wayland Back

Well, it was there so I tried it. Actually, I have some flicker after waking from suspend so I thought I’d login under X which worked great but I still had the flicker.
So I logged out and switched back to Plasma Wayland. Now I have a black screen with what looks like a blinking underline cursor in the top left corner.
I didn’t do anything under X except suspend then wake it up, and logout.

I assume running X changed something that is causing Wayland or Plasma not to load, or hang etc. CTRL+ALT+F keys doesn’t do anything, and CTRL+ALT+Backspace doesn’t either. But hitting my power button puts it into shutdown mode. I always set my KDE power management that way just in case something goes wrong I’ll still have a way out that’ll shut it down properly.

I figured someone had to try X and then try and go back under Wayland and may know what it does. I’m running Nvidia and fully updated Tumbleweed.

That’s likely the problem. My understanding is that Nvidia support with Wayland isn’t very good.

Using Intel graphics, going back and forth between Wayland and X isn’t a problem.

I’m still looking around. The journal didn’t have a lot but I found this.

Contents of: ~.local/share/sddm/wayland-session.log

startplasmacompositor: Starting up...
dbus-daemon[5376]: [session uid=1000 pid=5376] Activating service name='org.freedesktop.systemd1' requested by ':1.1' (uid=1000 pid=5406 comm="dbus-update-activation-environment --systemd --all")
dbus-daemon[5376]: [session uid=1000 pid=5376] Activated service 'org.freedesktop.systemd1' failed: Process org.freedesktop.systemd1 exited with status 1
dbus-update-activation-environment: warning: error sending to systemd: org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
No backend specified through command line argument, trying auto resolution
dbus[5409]: arguments to dbus_pending_call_block() were incorrect, assertion "pending != NULL" failed in file dbus-pending-call.c line 765.
This is normally a bug in some application using the D-Bus library.

  D-Bus not built with -rdynamic so unable to print a backtrace

I don’t understand how it worked then just quit after only logging in/out using X. I’ve read awful lot but this is all new to me. I used the same distro, Mageia, for about 20 years from back when it was Mandrake. Plasma and Wayland are both new to me and I’d like to at least understand them enough to fix things like this. I understand Wayland is new too, and Plasma isn’t 100% yet, but still, even when it’s all running like a champ you’ll encounter problems from time to time. This is a good time to start snooping around and learning about it. Thanks for the reply and I will post what I find. I read another post by a guy who had Wayland working with Nvidia but he didn’t give any details. I didn’t even know I was using it and I’m starting to think that I may have been using X even though Plasma Wayland was showing in the greeter. I have read other people say that’s what was going on with their system but it was a different distro.

Actually it is not supported at all.

NVidia doesn’t provide the necessary functionality, they have their own “solution” that would require specific support from the compositor.
NVidia offers patches for Weston (Wayland’s reference compositor) AFAIK, but not for kwin, and kwin’s maintainer doesn’t want to add nvidia specific code to kwin either.

See https://blog.martin-graesslin.com/blog/2017/10/plasmawayland-and-nvidia-2017-edition/
It should work with nouveau though.

PS: Have you actually tried to reboot before logging into a Wayland session again?

The error messages you post seem to indicate some problem with DBUS and/or systemd/logind.

Yes, I did try a full reboot etc. I played with everything a while longer, a couple of days I think, then reinstalled everything and don’t want to mess anything up this time. I usually do that when I first try a distro. I fiddle with everything with a “why not” or “let’s see what this does” attitude, then reinstall it and act right. I hope to have this same install years from now.

I was over in my forum settings when I noticed this. I was setting up notifications so I don’t miss posts like this.