Log Out, Shutdown and Restart does not work (12.1 - KDE) !!!

Hi All,

I have recently upgraded my OS from openSUSE 11.4 to 12.1 (64-bit).
As such, there was no problems while upgrading. However, after complete
installation (upgrading), I am finding some of the issues, which I thought of
listing here, so that some experts can answer:

**(1) While I am trying to logout the session from KDE 4.7.2,
Log Out
Shutdown
Restart
Either of these three does not work.
Monitor just changes the color (fading)…and does not do anything.
**

Nevertheless, let me mention that - I am able to shutdown the laptop
through console by giving “shutdown -h now” command.
Similarly “reboot” also works…but for this, I have to be root everytime.

**(2) Now my sound card also is showing some problems. When i test the
sound card through yast…it plays test sound…and everything OK.
However, banshee does not play any sound. Though stramer keep moving
showing that song is being played, but no sound.
**

**(3) Finally, my VLC is also showing no sound. There is no problem in video part,
but no sound again.
**

I would highly appreciate, if some experts can clarify my doubts.
In the meantime, I am parallely searching other similar threads.

Some more information:

My Laptop:

ACER 5920
openSUSE 12.1

Let me know, if I need to provide some more details.

DBS.

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
>> Dr. D. Bala Subrahamanyam, Scientist/Engineer - ‘SE’
>> Space Physics Laboratory, Vikram Sarabhai Space Centre<http://www.vssc.gov.in/>
>> ISRO <http://www.isro.gov.in/> - Dept. of Space, Govt. of India
>> THIRUVANANTHAPURAM - 695 022, INDIA
>> Ph.: +91-9895656150(M); +91-471-2562553(O); Fax: +91-471-2706535
>> E-mail: subrahamanyam@gmail.com; subbu_dbs@yahoo.com
>> My Homepage: HomePage - Welcome to Subbu’s HomePage
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

On 2012-04-05 09:16, subrahamanyam wrote:
> I have recently upgraded my OS from openSUSE 11.4 to 12.1 (64-bit).

How exactly did you upgrade?

There two methods, online (zypper dup) and offline (DVD boot and choose
upgrade). Which one?


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Hi Carlos E.R.,

I have done upgrade through DVD Boot.
Can you further help me out ?

Thanks and Regards,

DBS.

On 2012-04-05 21:06, subrahamanyam wrote:
>
> Hi Carlos E.R.,
>
> I have done upgrade through DVD Boot.
> Can you further help me out ?

Yes, read this and apply:

Offline upgrade method

Easier than writing it all here again :wink:


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Thanks a lot Carlos,

I would go through it and will get back if I still face some problems.

Thanks again for your quick and friendly response.

DBS.

Hi Carlos and Other Readers,

I gave some more attempt to solve my problem. Not 100% success, but somehow I could fix my SOUND issues.

I opted by upgradation of my packages through “zypper up” in root console.
It did several updates, so can not say - which one was responsible for repairing my sound system, but thats done.

My “log out” and “shutdown” issues remain unsolved.

I have seen in this sub-forum various similar queries…so I would look for a feeble solution and if I succeed, I would
share it with you all.

Thanks.

DBS.

On 2012-04-07 15:06, subrahamanyam wrote:
>
> Hi Carlos and Other Readers,
>
> I gave some more attempt to solve my problem. Not 100% success, but
> somehow I could fix my SOUND issues.
>
> I opted by upgradation of my packages through “zypper up” in root
> console.
> It did several updates, so can not say - which one was responsible for
> repairing my sound system, but thats done.

Good.

> My “log out” and “shutdown” issues remain unsolved.

Mmm. I would verify in yast (yast2 --qt sw_single &) that you don’t have
orphaned packages. Or use the rpm query method.

The other remaining issue possible are old obsolete configuration files
(specially around pam) - the link documents how to handle that, although
perhaps not in detail. It is a section I have to improve.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Thanks Carlos,

I am checking the “pam” configuration files and found that some of them needed to be installed.
Right now, installation of those packages is in progress.

I will update once all packages are installed/updated.

Let me see, if “log out” and “shutdown” problems are also rectified.

DBS.

You need to install vlc-aout-pulse (VLC Audio Out for Pulse Audio) package.

Thanks to One and All for your suggestions.

Finally, I could fix all the problems one by one.

After upgrading all my packages through zypper, most of the headaches were over.
Those, who are experiencing similar problems may try the following option:

(1) Go to console as a root user. Ensure that your internet connections are established.
And then use “zypper up” command.

Precautions: The above command would upgrade several of your packages depending
on how latest are your codes. Thus, this command can lead to a heavy download of
about 500 MB of packages…so be ready for this.

(2) Through YAST, I also searched some more packages “PAM” etc…and allowed them
to be upgraded + installed.

(3) Finally, I played with my “Personal Settings (Desktop)” and did some R & D in required
places. If your “banshee” is not working fine…just change the GTK…style to something
other than “Oxygen”…it works fine.

Happy Endings…so I am happy.

And now, it is almost 7 continuous years of my LOVE AFFAIR with openSUSE.

And I am in no mood to go for divorce…

Long Live…openSUSE.

SUBBU.

Same problem has occurred here – once so far. Thanks for starting this thread, subrahamanyam.