Log In Freezes/ Xauth: timeout in locking authority file /home/sifu/.xauthority

I have a fresh install of Open Suse (Gecko) Linux KDE42.2 and it was running well but I couldn’t access the other drives on the desktop.

Elementary OS and Voyager Linux (other distro’s that are installed on this desktop) had an id of 1000 but the fresh install of Gecko was 2001 so I fixed the uid issue with this to make all of the id’s match.
These are the commands I used to fix the uid problem. Also I’ve posted output that dropping to a tty shell is currently giving me.

usermod -u 1000 sifu
groupmod -g 1000 group
find / -user 2001 -exec chown 1000 {} ;
find / -group 2001 -exec chgrp 1000 {} ;

When I try to log in the screen locks up.

Dropping to tty gives me this:

xauth:timeout in locking authority file /home/sifu/.xauthority

cannot open log file /home/sifu/.local/share/xorg/.o.log please consult the x.org Foundation support http://wiki.x.org

xinit failed ./usr/bin/Xorg is not set uid, maybe that's the reason?
If so either use a display manager or adjust /etc/permissions.local and run chkstat --system --set afterwards

xauth: timeout in locking authority file /home/sifu/.Xauthority

How can I fix this?

Check the owner of .Xauthority If you run a GUI as root the ownership of that file can get changed to root

How do I check the owner of .Xauthority and change it to root?

I’ve never done that before.

I was able to pull up the .Xauthority file and this is what it said.

-rw------1 1000 Network 52 Jun 30 12:53 /home/sifu/.Xauthority

Do I need to change it?

No it is owned by UID 1000 which should be you. You DO NOT want it owned by root which can happen if you log into a GUI as root which you should never do. If Gecko uses 2001 I’m not aware of this. Using the same home for several flavors of Linux can be a challenge I suggest you use a different user name and thus a different home directory for each OS since details can differ. They may use different versions of Desktop or other software and the configs may not be 100% compatible.

Also you need to be root to change other users (UID) files become root with su or use sudo

When I installed Gecko the uid was 2001. I had to change it to 1000 because I couldn’t access the other 2 HDD’s on that machine. I used these commands to do it:

usermod -u 1000 sifu
groupmod -g 1000 group
find / -user 2001 -exec chown 1000 {} \;
find / -group 2001 -exec chgrp 1000 {}/;

I was root in a tty terminal to change it to 1000.

I still can’t log in. Any ideas?

I use Yast to change groups and UID

Check the sifu directory what are the permissions?

It is a permission problem :wink:

Also note this from the man files

You must make certain that the named user is not executing any processes when this command is being executed if the
user’s numerical user ID, the user’s name, or the user’s home directory is being changed. usermod checks this on Linux,
but only check if the user is logged in according to utmp on other architectures.

Not sure what the permissions are on the sifu directory.

I went ahead and performed a fresh installation and it went well.

I didn’t know that you could use Yast to change groups and UID’s.

How do I use Yast to change the UID?

Thanks for staying with me.

Yast -Security and users

Any file browser right click - properties - permissions

ls options (see man ls for details)

I found it thanks!

It’s in Yast under User and Group Management in Gecko Linux.

Happy Fourth!

Marking the thread Solved:-