Log in and suspend slowness issues in the system

@non_space no that’s fine, have you restarted sshd and tried to log in?

Assuming /etc/ssh/sshd_config.d/01-ssh.conf exists…

OK . . . had not tried to restart, but it shows that the file “exists” . . . but again permission denied.

Do I need to reboot the system or log out and then back in?

cat /etc/ssh/sshd_config.d/01-ssh.conf
PermitRootLogin yes
PasswordAuthentication yes
no:~ # systemctl start sshd
no:~ # ssh 192.xxx.xxx
(root@192) Password: 
(root@192) Password: 
(root@192) Password: 
root@192's password: 
Permission denied, please try again.

@non_space the change is made on the ‘host’ you want to connect to, you need to be on the remote machine and as your ‘user’ ssh 192.xxx.xxx.xxx

OMG . . . I thought we were working in the TW system to set up “ssh” . . . and then we were going to do something . . . .

So, now I’m supposed to run the from another computer??? But that machine will also have the same IP address?? Or it’s using the same internet connection . . . .

And, then I’m just checking to see what happens if I run that IP address in the other machine??

Still wondering if this is easier trying to “chroot” in from another partition on the same machine?? I’m not clear on what the purpose of this ssh exercise is?? I did have access to the TTY, this is a GUI slo-mo problem.

So, all of these files and commands were supposed to be run on the “remote” machine??

I just tried to “start sshd” in a manjaro based machine and I ran the ssd that we have for the TW machine . . . “port 22: no route to host” . . . was the reply. I’d have to get another machine that has a Gecko system in it, then try the same stuff that I was making in the TW machine . . . and then try it again??

@non_space You want to connect from machine 1 (the client) to machine 2 (the remote), where machine 2 is the system your having a problem with. Machine 2 requires sshd running and the config. Nothing needs to be done on machine 1 except connect to machine 2 over ssh…

1 Like

OK . . . so we have machine two with sshd started . . . but now on what I used for machine 1, running the basic “ssh IP address” that we were using previously to do what I thought we were doing . . . . Machine 2 was also saying on the same “port 22” Machine 1 says “no route to host” . . . ??

So, again, never having run or used “ssh” on any system in the past . . . anything to do?? Or, this was a problem with Manjaro not providing ssh in their basic system . . . so I’ll have to jump over to the laptop that has Gecko install and try from that machine and hopefully Gecko rolling provides an option for ssh??

@non_space so you don’t need sshd running on machine 1 (the client, geeko, windows, manjaro etc), you just need to run ssh machine_2_ip_address which you got from the command ip a AND assuming they are on the same network :wink:


That is what I did . . . although I believe I ran “#systemctl start sshd” on machine one first?? Thinking that I would at least need to “start ssd”?? before I ran the “ssd IPP address”??

Was that the error?? I was just supposed to run the command?

Yes, they are both on the same network.

@non_space so you can ping the remote machines ip address from the client?

It’s the remote machine, you run systemctl start sshd

OK, comedy of errors I did run the #systemctl start sshd on the remote, and then I ran the ssh IP number from the remote and it still is saying “no route to host”

Again, don’t know anything about manjaro’s ssh options.

Just checked and openssh is installed in the Manjaro remote system . . .

OK, your flip flopping or me :wink:

Lets clarify, the ‘REMOTE’ machine IS the machine with the issue, you need the ip address from this machine AND have sshd running…

The ‘CLIENT’ is any device your connecting from that can run the ssh command…

1 Like

OK, flipping out is more like it.

So, I just “started sshd” on the TW “remote” problem system . . . then I went to the Manjaro machine and typed “ssh IP number” and it still says, “No route to host”

Does this get back to my questioin earlier where I asked about YaST >Remote admin settings?? Along with the config file do I need to “allow remote admin” and check the “firewall port” to on? I didn’t get a response to that question . . . .

@non_space no that’s an issue with the client, can you ping the remote system ip address?

ping the IP number shows activity “31 packets transmitted, 31 received 0% packet loss”

Just about out of time for this project today . . . there were another 19 packages that got upgraded today, some things improved, like the launching of apps . . . the log in problem still continues.

Thanks for playing . . . I’ll check back tomorrow.

1 Like


Cold light of day, tried it again … . machine 1 still saying

macbookpro54 ~]# ssh 192.168.xxx.xxx
ssh: connect to host 192.168.xxx.xxx port 22: No route to host

Tried it this time logged in as root, no difference. Slowness problems on the problem TW system persist . . . in spite of another 6 packages to upgrade via zypper.

There has to be a bug report in here some where, the question is, what to file it against? Kernel?

MATE desktop-session??? Several zypper dup’s over the week have not resolved the problem.

@non_space then you have some fundamental network issues if two machines on the same network can’t see each other…

Well if you skip login manager and autologin, all is good?

@non_space and both machines have the ip address in the range 192.168.xxx?

1 Like

Autologin is set in TW . . . which it does do “automatically” . . . but, as slowly as it was before when I would type the password . . . autologin goes to black for several minutes, etc. So, not exactly “good.”

IPv4 IP address numbers are one digit different, everything but the last digit is a match.

@non_space and the gateway address is the same on both systems