Locking up from boot at loading initial ramdisk after a 13.2 fresh install

The machine rebooted without any problems at the end of the install but when rebooted again locked up as per the title. The machine is an HP intel atom netbook. KDE desktop.

Any ideas?


Was this after running updates?

I thought it was down to an update so re installed again and then just rebooted without updating. The reboot from the install was ok. I ran the browser, connected to wifi, used kinfocentre, changes some power saving settings - then rebooted and it locked up.

The first time I installed the reboot from that was ok as well it even installed 2 updates and a lot of security updates. That requested a reboot which is when I found I had a problem.

It’s an odd place for it to lock up.


Just a wild guess: Do you use encrypted disks or partitions?


No :slight_smile: I have to lengthen the reply to at least 10 characters. ;)So i just have.


Have you run previous versions of openSUSE or other Linux OS’s?

It did have win 7 on it. Out of curiosity I installed Kubuntu on it but the software management is a let down and doesn’t come remotely up to YAST standards so as usual I ditched it and went back to OpenSuse. I am not sure if Kubuntu had the same problem. Just tried to install a few things I use from their graphical tool - it couldn’t locate any of them. Apt-get etc may be great assuming some one knows what to get. YAST allows description searches which helps a lot on that score. Even knowing the name of what I wanted to install didn’t help Kubuntu.


Assume you actually had a working internet in Kubuntu? apt could refresh all the sources no trouble?
Probably the best UI package manager for Kubuntu is Muon Package Manager and not Muon Discover.
Different Distros have different methods for sure. But it would have been interesting to know how Kubuntu 14.04.1 performed.

I found it as before. Mainly aimed at “typical” use. The package side can be an issue. On Ubuntu and others as I see it most information on that score comes from searching the web on an I want to do this basis. Generally I find that giving YAST a clue and searching descriptions does the job. If I want to do something unusual I find both Ubuntu and ARCH forums useful via web searches.

Performance wise after an install I would say that it was quicker than OpenSuse but I have made some changes and now there is no difference as far as I can see.

Last time I installed 32bit Kubunto and then installed 64bit OpenSuse. There was some strange behaviour during partitioning in install. It didn’t just come up and offer me one but button presses seemed to cure that.

I wiped the boot block with dd and then forced a complete NTFS disk format and then installed OpenSuse 32bit. Speed wise it’s very similar to Kubuntu even on the rate that the install ticks come up. Probably faster actually. It was a bit slow on the 64bit. This time it did propose partitions so I just clicked ok. Maybe it assume that if Linux is on it people could sort that themselves - that wont always be the case.

The problem has changed now and may offer some clues. If I just boot from the hard drive the same thing happens. If I leave the install dvd in so that it boots to that and then select boot from hard drive all is ok. :’( I may have another problem as well but best leave that for later.

When booted like this a console style message concerning power management time out pops up plus closing pipe ?? it’s a bit quick to be precise but it then goes on and boots. Firefox runs as does Kinfo’.


I am very confused by your latest post.

Are you using MS-DOS partitioning or GPT?

What filesystems are you using? (You said you formatted with NTFS after dd???)

What does your disk layout look like?

Maybe post the output of:

fdisk -l


parted -l

Perhaps also try:

gdisk -l

This may give a good starting point.

And, do you have the same problem if you choose the Recovery entry under Advanced Options on the Grub menu?

Of course, I do think you know what you are doing, but you sure left me confused.:wink:

I have had a similar issue on a Compag Presario 64 bit with Intel processor. Used KB3 to download and burn the 13.2 Iso, was running effectively Version 12.2, but the disk was starting to crack up around the center and would not always work correctly in the drive.

Everything appears to be ok. Only error was related to boot manager, modified to Root and checked both boxes below as described by HELP and it installed and started ok. Never would start KDE or Gnome though and always kicks me to grub.

System sometimes locks up in Grub. Not always. So, is there a way to start KDE under Version 13.2 from GRUB? Anyone knows why its locking up on the 64 bit version?


I was also not able to find a working iso for 12.2 or 12.3 on the repositories.

I should have been clearer about why I forced a whole disk windows format. dd cleared the boot block without any problems, 1/2 hr and it still hadn’t cleared the disk. Forcing an ntfs format cleared it in about 20min. I wanted to clear any signs of previous installs. Also as installing over Kubuntu prevented the OpenSuse install from correctly suggesting a partition layout I wanted to see if it worked correctly if there was something windowsey on it. It did. The subsequent opensuse install of course reformatted the lot as it should do. XFS and for some reason btrfs for var/tmp

This thread is about 13.2 not 12 etc.


You do know that a format is not the same as zeroing out each sector. Format only builds the skeleton of the file system it does not write to each sector

No, my lockup was directly after installing 13.2 and when it rebooted it kicked me into GRUB. Sometimes it locked up, other times it did not. If I go through Recover is there something I can do as root to get KDE to work? All of the drivers have appeared to load correctly, but the links are not right maybe?

mkntfs writes zero’s all over the disk unless the quick option is used. It takes ages so generally people use the quick option. It still much quicker than trying to do it with dd but that or something similar is need to clear the boot block.

What I suspect is happening is that all is ok when boot from hd is selected from the menu on the install dvd because it has loaded the ramdisk already. For some reason it wont load directly from the hard drive.

Once it is up and running KDE loads and all so far works. I did think I had a problem with YAST but that runs now too.

The only thing that may be unusual about my install these days is that I do have a separate root account as I don’t use sudo at all. These days it seems a lot do. I also don’t allow it to boot through to kde. I have to log in to that each time I reboot. When it does run these aspects are fine. The root account works and it allows me to log into kde. I haven’t tried logging into KDE as root but it should allow me to do that as well.

Not being able to have a root account is one of the things I don’t like about the Ubuntu stable - well at least it didn’t have one last time I thought I had set one up on it some years ago. Looked like I had but hadn’t in practice. They seem to hijack it for some reason.


First off default in openSUSE is to have a real separate root account. sudo exists but is not exactly the same as in Ubuntu though it can be modified. In any case you should never ever log into a GUI as root. there is never a reason to do that and you can break stuff totally by accident by inadvertently changing ownership of users files. This is because GUIs have a habit of opening files in the background and owner ship can change and break the regular users home. If you need to be root become root temporally using su - or su Note the dash with the dash you get the full root environment with out the environment is still the users. I have used openSUSE for years and never logged into a GUI as root at least not since I broke my home by logging in as root back in 10.1 days. :P.

Can I suggest.
You install 13.2 following this example
It’s 13.1 but it matters not

The part I’d like you to follow in particular is to get to setup the install as an expert
And I’d like your install to be to a root and home that are both ext4

Yes, I too think this would be a good idea, and was thinking along the same lines.