Locking Screen

I cannot seem to get my screen to lock after my laptop sleeps. The screen comes up asking for a password, but then I have full access just by touching the trackpad or moving my mouse. I’m using 12.3 with a Sony Vaio.


I guess you are using KDE, right?

Please run “Configure Desktop” (aka systemsettings).
Select “Power Management” and click on “Advanced Settings”.
Please make sure that all options are checked there. (esp. “Lock screen on resume”)


And? …

System Settings > Display and Monitor > Screen Locker; check “Start automatically…” and “Require Password…”.

That solved the problem. Thank you so much!

Good news, and thanks for letting us know.