Locked out of YAST??

Very odd - I went to install kdiff and YAST won’t acknowledge - I type in my password in the KDE window and the window freezes… nothing. Can’t obtain root for konsole super-user-mode either. Everything else seems to be operational. If I start konsole and issue su command, it accepts the correct password. I had just done a packagekit update of MPlayer. Help?

Something failed in your Plasma session. I would try logout and then login to see if that fixes it.

I should have mentioned that I tried rebooting and shutdown/reboot but that did not fix the problem.
So I just tried your suggestion of logging out and back in, and that seemed to fix it. Am I surprised! Anyway, I’m glad my system wasn’t being hacked. Thank you!

I still have Leap 42.3 on one of my computers, though I rarely use it.

When I last used it (to update in early November), Plasma was malfunctioning. I logged out and logged in again, and all was fine.

My experience is that if I delay login after boot for long enough, then this doesn’t happen. If I login too quickly after boot, it does. I think there’s a timing issue when the system is still busy from booting up.

I have not had this happen on 15.0. But maybe something like that is happening for you on 15.0. If so, it is probably a Plasma bug to have anything where the timing is that critical.


YaST uses and needs the user “root”.

Are you absolutely certain that, the user “root” is OK?
Can you login to the user “root” via a VT (tty1 … tty6)?
From a “normal” user’s GUI Terminal window, does “su --login” behave as expected?

If not, you’ll need to boot an installation DVD and use the “repair” mode to repair the “root” user’s login directory …


Please try the following test:

  • At a VT (tty1 … tty6) username prompt, type in the “root” password and check that the characters displayed are in fact those of root’s password.