lock/logout plasmoid not reading KDE default logout setting

Clicking the lock/logout plasmoid, the computer shuts down, BUT the default KDE logout selection is set to restart

How do I fix this? Thanks in advance for any help I can get.

It’s been 11 days and not one reply? No ideas? Why?

Possibly because it’s not being seen by other users?

Have you tried with a new clean user profile to eliminate (any other) user settings?

There have been recent reports of problems with Reboot, Shutdown, and Logout. See, f.e. https://bugs.kde.org/show_bug.cgi?id=422870 and https://bugs.kde.org/show_bug.cgi?id=423391

These have been traced to a typo in the source code, and a race condition.

Perhaps you’ve just found another variation… ?

If you’re able to consistently produce the bug, then a bug report over at KDE’s bugzilla wouldn’t go amiss.

FWIW, I’m not able to reproduce the problem on either my Leap 15.1, or TW systems.

Thanks. I tried to file a bug, but the search shows it is a plasmoid, so it doesn’t show up.
So I guess I have to got the plasmoids list and find it and report it there. Thanks for the little tiny minuscule bit of help.