Locale problem - delete and arrow keys don't work

Hi,

I am a new linux convert, and I settled on suse because I wanted a ubuntu build that was up to date and using KDE. That being said I first tried linux mint and I have had a lot more problems getting everything to work.

I’ve sorted most of it out now but one re-occuring problem : I am in Canada, so I set the locale to US english. Now, the delete key on my logitech ex110 keyboard brings up the screenshot application and does not work as a del key. The arrow keys also do not work (for moving cursors etc.)

The trick is, if I change it to say, Canada, for the locale in Yast->Hardware->Keyboard then it works as expected - until I reboot. Although the local is still set correctly del and arrows again do not work.

If I switch it back to US it works again until I reboot. This process can be repeated ad-infinitum, switching to UK or Canada or US and it works until the next reboot.

Can anyone give me a reason this might be happening? Its seriously affecting my whole linux experience as I use all of those keys extensively.

Thanks in advance.

P.S. It’s a wireless USB keyboard but I don’t think that is the issue, it seems to be a kb layout problem in the setup.

Jason

bump

I found this :

Re: [opensuse] new issue in SuSE 10.2: “Down” and “End” key always bring

which talks about xkeycaps but after generating a new file, I don’t know where to put the line to load it … it said to put it
in the use logon script.

Help, please.

Jason

I experienced also similar behaviour on OpenSUSE 11.1. In GDM login dialog down arrow key behaved like Enter and after login ‘delete’ key invoked gnome-screenshot application.

I tried your language change proposal and also X mapping but without success. After replacing xorg.conf with my old functional one I found that it is something configured wrong.

Result:
I disabled evdev mouse pointer in ServerLayout configuration. This is equivalent step like you do in SaX when disabling the one pointer with this driver. Keyboard behaves correctly now.

FYI: I also commented “ZapWarning” because of annoying PC speaker sound when restarting X.