Local SDD not seen when installing UEFI

Hi follks,

I’ve tried finding some installation tips and look through the forums this morning for a solution, but nothing seems to come up so I’m probably not using the correct search terms in the right order.

I just received a refurbished Dell 7400 laptop with Win10 pre-installed and I want to switch it to running Tumbleweed. It’s a UEFI system, so I used Rufus to install 64-bit Tumbleweed to a UEFI thumb drive. On boot, I’ll hit the F12 key and I can see the Thumb drive, the local hard disk, and the Windows Boot manager that can be selected for booting. If I boot from the Tumbleweed thumb drive and start the installation, once I hit the step to install to the laptop hard disk, the device isn’t listed, only thumb drive volume.

I’m sure I’ve not set the correct UEFI or other boot settings in the BIOS, right?

Thanks for any suggestions!

Recent DELLs ship with a default “RAID” setting in the UEFI firmware that prevents Linux from seeing the disk (is it a NVME card?).
If so, disabling that “RAID” setting should make the internal SDD visible, but also nuke your Windows install.
Search the internet or ask here if you need help with it, there are workarounds (but I don’t recall the details at the moment).

This thread apparently deals with the same problem: https://forums.opensuse.org/showthread.php/538928-15-1-install-on-SSD-installer-doesn-t-seem-to-recognize-the-SSD

Thank you OrsoBruno, your suggestion about the RAID setting instead of AHCI was the problem! Thanks also for the forum thread pointer, that makes more sense now why that is enabled by default for Windows systems. Tumbleweed installation is now seeing the local SSD.