Local network

I have a local network of 5 computers. the two of them are running windows and the other 3 suse (10.2 , 10.3 and now 11). I cannot see the files of the windows pc to the one setting up now with the suse 11. The pc has internet, makes ping to other and i can open through network/smb-network only if i type the name of the windows pc that i want to see the shared folders. But i cannot see in everyone folder, for some of them i get an error that the smb is terminated…

In openSUSE 11.0 →
There is a bug in KDE4 for Samba. There is a bug in Nautilus for Samba. There is no bug in KDE3.5.9 for Samba.

Question 1: So which desktop are you using of the three?
Question 2: Hard for me to understand. Is it this: The 10.2 1nd 10.3 are OK but the 11.0 is not OK – is that it?

i use Kde 4.04…

yes both the other suse system are working fine…

OKM check the Samba configuration file smb.conf to see that these lines are in the [global] section:
name resolve order = bcast host lmhosts wins
map to guest = Bad User
local master = yes
os level = 33

And make sure doesn’t contain these (assuming you not using domains or wins servers):
wins support = yes
wins server = xyz.abc.def.ghi
security = domain
domain logons = yes
domain master = yes
preferred master = yes

Check you have added a user or users to the samba user database.

As a diagnostic measure, turn off SuSEfirewall until the LAN browsing works.

Check that nmbd and smbd are set to start at boot

Restart (with the firewall set to not start)

Let it settle and check in your console this command:

smbtree -N

and see if the shares and servers appear (might have to reboot the lan twice to force them all to chat nicely).

i get:

smbtree -N
\OEO\J$ Default share
\OEO\Ntokymanter - Shows
\OEO\C$ Default share
\OEO\N$ Default share
\OEO\ADMIN$ Remote Admin
\OEO\F$ Default share
\OEO\M$ Default share
\OEO\G$ Default share
\OEO\print$ Printer Drivers
\OEO\IPC$ Remote IPC
\OEO\CanonPIX Canon PIXMA iP5000
\OEO\E$ Default share
\LENIW Samba 3.2.3-0.1-1882-SUSE-SL11.0
\LENIW\homes Home Directories
\LENIW\IPC$ IPC Service (leniw (toshiba laptop))
\H2O h2O (Samba Server - openSuSE 10.2)
\H2O\homes Home Directories
\H2O\IPC$ IPC Service (h2O (Samba Server - openSuSE 10.2))

but when i try to access the server oeo, which is the windows file server, from Konqueror: remote:/smb-network , i get an error that the smb died o unexptectly… when i type remote:/smb-network/oeo i get the folders of the system, but i cannot access all of them, just the Ntokymanter and Software… for the others i get the same error…

Your results from smbtree show that Samba networking is fine, you can see the windows file server and the Suse machines. So problem is in network GUI browser.

I got the same result as you in KDE4.0, same error message too. It’s a bug in KDE4.0. It corrected itself you me when I upgraded KDE4.0 → KDE4.1. To do that add the KDE/Suse factory repository to Yast and upgrade KDE4. GoTo Yast → Software → Software repositories → Add → Community Repos → openSUSE Build Service KDE4 Factory Desktop.
The start again in Yast → Software Management → Patterns → KDE4 Desktop Environment: Right click on the RHS panel an entry and select → all in this list → Update if newer version available.

That should get the network browsing working in Dolphin → Network → Samba Shares

thanks… i didnt want to upgrade to 4.1 because i had problems the last time… but now it seems ok…
At the network now, i get the workgroup and the computers, but i still open the same folder in the windows system… at the other i get the same error… i have tried and other two folders… the one has 5-6 files in it and i can see it… but the second has over 90000 files and i get the same error… Can the problem be at the number of files that the folder has?

I’m finding it difficult to understand.

Is this the situation:
We are talking about these three Samba members:
OEO a windows xp computer
LENIW a Suse 11.0 KDE4.0 computer upgraded from the latest factory repositories to 4.1
H2O a Sose 10.2 computer

Every computer can see every other computer and all shares and files EXCEPT that LENIW can’t see into ANY folders on OEO the XP server. Instead you get this error:“smb died o unexptectly”. But it can see the files on H2O.

Is that correct?

yep… i get this error only for some shared folders of the oeo when i try to access them from the leniw…

I can’t imagine why unless there’s something consistent about them like being all the Drive$ shares with special permissions or something. But if it’s not in Suse 10.2 I still put my money/bet on the inadequacy of KDE4.

The official advice is that Suse 11.0 KDE4 is only experimental; which in my mind translates to “don’t use it for anything important”. I suggest you file a bug report with the Novell Bugzilla for Suse 11.0 so they can try to fix it for 11.1.

If i share any folder inside the parent folder that i cannot see from leniw… i can see it…

hm… ok… thank you anyway… for your time…