LiveCD with Asus M3A

I have an ASUS M3A board with
Video Card:GeForce 9600 GT NVIDIA
Forceware Ver. 174.16
Memory 512 MB
Bus PVCI Express
Video Bios Ver 62.94.0d.00.71
Monitor : 2- Dell 248WFP
Processor: AMD Phenom 9500 Quad-Core 2.2Ghz
Memory: 1.00 GB ram

When I use the livecd it will start to boot I get greenscreem welcome then the choice menu I checked media and it passed. I tried all loggins and none worked after it loads a bunch of line commands all pass it goes blank.

When i load the Livecd in my Dell Intel the software boots up fine. I get a constant green screen with a status bar while its loading instead of the command line load on the Asus. I checekd Linuxcompatible.com and the M3Aboard seems to load up for other people.

What am I doing wrong???

Did you try vesa graphics mode
I think press F3 at the boot menu and select

Yes I tried all Video modes. I just wish I understood what is happening any other suggestions??

I did try text mode and while it gave me an error at the end saying it could not load due to a virtual machine load error i did manage to get a login prompt after a CR and I typed root no password and it gave me a prompt and said have fun I quickly tyed yast and i got the yast menu then i went to graphics card and monitor and pressed enter and it went blank again.