LiveCD Installer Trying to Delete EISA Partition

Hello,

Firstly, I’ve never used Linux before, but have to now for a new research project. I’m trying to install it on my machine along side XP. I originally had a XP/Vista dual boot setup, but I blew off Vista, reformatted the HD, and installed XP thinking that would solve my problem (plus I didn’t really need Vista), but it didn’t. Anyways, my problem is that when I boot to LiveCD, run the installer, and get to the section about partitioning, YaST wants to:

‘Delete partition /dev/sdb1 (9.77 GB)’ (my EISA partition) and

‘Delete Windows partition /dev/sdb2 (48.83 GB). Resize impossible due to inconsistent fs. Try checking fs under Windows.’

I already ran dskchk /f in windows and it didn’t fix the error. I tried manually creating the partition setup, but then I get an error saying that my /boot partition is after cylinder 1024 and that my BIOS won’t support that.

So what do I have to do here to install OpenSUSE 11.1 alongside my already installed version of XP and not delete my EISA partition?

BTW, I ran fdisk -l in the LiveCD app, but I can’t copy/paste the results here because the computer isn’t hooked up to the internet. Is there any way I could get it connected to the internet in the LiveCD app? I’m on a network here in my office, so I would have to manually enter the IP address, DNS server, subnet mask.

Thanks a ton if anybody can help me with this,
I’m going on 2 days working on this problem now

When using the live cd, Try pressing print screen when you have the fdisk -l

It will take a screen shot. save the file to a usb drive and post the image on imagebam.com
Then link us to it by posting the BB code imagebam gives you

http://thumbnails6.imagebam.com/3995/ba070139949075.gif](http://www.imagebam.com/image/ba070139949075)

Try and explain to us what is on sda
and sdb

What is EISA Partition?
OK sorry I just G’d it:
http://www.google.co.uk/search?q=EISA+Partition&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-GB:official&client=firefox-a

The installer is working with sdb not sda

again explain what is on the two HD’s

sda is an extra hard disk that was laying around my office. I threw it in the computer to back up my files on. sdb is the the hard drive xp and my EISA are installed on and it is the hard drive I want to put openSUSE on, as you mentioned.

So what are all the linux partitions in sdb? 5,6,7,8

They’re from a previous install of openSUSE. I created my own partition setup, but when I got to the install portion, a slew of errors popped up. I guess it set up the partitions, but I couldn’t boot openSUSE. Windows XP started after restart instead of going to the GRUB bootloader. I’m not sure if the problem was with me not mounting the windows partition or if it was because the /boot partition was after cylinder 1024.

OK. So assuming you don’t need anything in the old Linux partitions. This what to do.

You see sdb5,6,7,8
They all reside inside sdb3 (The extended partition.)

Delete sdb5,6,7,8. This you do by following this route at install:
At this page choose: http://files.myopera.com/carl4926/albums/671478/8.png
Partition Based/Create Partition setup.

At the next screen: http://files.myopera.com/carl4926/albums/671478/9.png
Choose Custom Partitioning

This will take you here: http://files.myopera.com/carl4926/albums/671478/13.png
Where you can see your disks. And work down the tree of sdb on the left, select each of the partitions and delete.

Then create 3 New Partitions within sdb3
/ (root) allow 15GB
swap (2GB)
/home (all the rest)

Then just make sure you set grub to MBR as shown here: http://files.myopera.com/carl4926/albums/671478/19.png
You get here from the install summary screen and click on the ‘Booting’ title.

Okay, thanks, I’ll try that. However, is it necessary for me to ‘mount’ the partitions containing windows and my backed up files so that I could access them in SUSE? If so, how would I do this?

Nevermind that last post - I believe I figured out how to mount the windows and backup files partitions. So, I started installing and came up with error: -1014. Apparently, the old Linux partitions couldn’t be deleted. So I went ahead and deleted them by hand in the terminal and rebooted the machine. I started installing again after setting up the partition table (note that the linux partitions were now gone - only the EISA and windows partitions remained). This time I got error -3008 and it says unable to mount 16.1 GB media. Now I’m at a loss. Please see the screenshot of the errors I’ve encountered.

http://thumbnails13.imagebam.com/4003/c2b22e40028579.gif](http://www.imagebam.com/image/c2b22e40028579)
Free Image Hosting by ImageBam.com

I ran fdisk -l right after receiving this error and here’s what I got.

http://img2.pict.com/f7/c2/e2/b76171a3f1136c0c3f4e2761b1/huLX2/800/after.png

Note that sdb3 through sdb7 were not there before I started the install.

Edit: I’d like to add that, feeling curious why this install was so screwed up, I went ahead and installed OpenSUSE 11.1 on my home computer last night. The whole process, from start to finish, took about 1 hour with no problems. I didn’t have to mess with creating my own partition table - YaST offered to shrink my two existing windows partitions to make room for SUSE. However, I went into create partition setup, selected my second hardrive, and selected use entire drive. I didn’t get any errors saying the selection is invalid, like I do on my office computer. Installation went off without a hitch. So I’m aware that it can work easily, but I can’t figure out what the difference is between my office and home computer that’s causing these problems. Perhaps the EISA partition? Perhaps because my office machine has a SATA HDD while my home machine has an IDE HDD?

You don’t have to mount them. But I would.

In the partitioner when you setup linux partitions /, /home, swap
Select your windows installation partition and by default it sould be set as ‘Do Not Format’, in the mount point drop box you have to manually type it in, you can call it anything but it must start with /
eg: /WIN_XP
or
/Evil_Empire

That’s it.

We may have to tweak a file later so you can write to it

Okay, so here’s an update on my situation.

From what I could deduce from that error, it seemed like the installer was trying to mount devices before they were formatted. So I used

su --> fdisk /dev/sdb --> n

to create an extended partition. Then I created 3 logical partitions after that, setting the sizes to 15 GB, 8 GB, and the rest of the disk space for the last one. Then I wrote the partition table and exited fdisk typing the ‘w’ command. I formated the 15 GB and last partition using the command:

mkfs.ext3 /dev/sdb#

where # was 5 and 7 for my two partitions. Then I formatted /dev/sdb6 as swap space using:

mkswap /dev/sdb6

After this, I entered the installer and selected ‘create partition table’. I didn’t delete or create any new partitions this time. I only mounted the ones I created in the terminal with /, swap, and /home. Entered the rest of my info and hit install (btw, I selected MBR for the location to boot GRUB from). Install went like a charm with no errors. I reset, but windows xp started right up. GRUB is a no show. How do I get GRUB to come up?

As a side note, I forgot to mount my windows partition and backup files partition.

Okay, nevermind once again, I figured out the problem. GRUB was installed to the MBR of my other hard drive instead of the one with the operating systems on it (sda instead of sdb). If I switch the boot priority, GRUB appears. I’ll look into moving GRUB to my primary hard drive.

Thanks for all your help in resolving this matter.

Crumbs what a do you had. Well done in working your way thru that and thanks for keeping us informed.:wink: