live upgrade from 11.1 to 11.2

ok after pouring over the internet for the last three days i give up and im asking for help

i just did a live upgrade on my suse box taking it from 11.1 to 11.2 and fallowed all the steps in the doc it all went fine except after it was finished i can no longer access the internet


dracula:~ # ping google.com
ping: unknown host google.com
dracula:~ # ping 4.2.2.2
PING 4.2.2.2 (4.2.2.2) 56(84) bytes of data.
64 bytes from 4.2.2.2: icmp_seq=1 ttl=57 time=12.3 ms
64 bytes from 4.2.2.2: icmp_seq=2 ttl=57 time=11.3 ms
^C
--- 4.2.2.2 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 11.334/11.865/12.397/0.542 ms
dracula:~ # host google.com
google.com has address 74.125.53.100
google.com has address 74.125.67.100
google.com has address 74.125.45.100
google.com mail is handled by 10 google.com.s9a2.psmtp.com.
google.com mail is handled by 10 google.com.s9b1.psmtp.com.
google.com mail is handled by 10 google.com.s9b2.psmtp.com.
google.com mail is handled by 10 google.com.s9a1.psmtp.com.

this boxs works as a router / dns / dhcp and all of the computers behind it work fine

so i know the internet will pass throw it but it will not reslove the hostnames in links ping or zypper

What is the output of:

grep hosts /etc/nsswitch.conf
cat /etc/host.conf

dracula:~ # grep hosts /etc/nsswitch.conf
hosts:          files dns
dracula:~ # cat /etc/host.conf
#
# /etc/host.conf - resolver configuration file
#
# Please read the manual page host.conf(5) for more information.
#
#
# The following option is only used by binaries linked against
# libc4 or libc5. This line should be in sync with the "hosts"
# option in /etc/nsswitch.conf.
#
order hosts, bind
#
# The following options are used by the resolver library:
#
multi on

That is looking OK.
I too have encountered several issues on upgraded systems.

Do you use networkmanager or traditional ifup method? Please show the results of the following commands from the command line:

cat /etc/resolv.conf | sed -e "/^#/d"
/sbin/ifconfig
/sbin/route -n

/etc/resolv.conf should contain something like:

search mylocaldomain.tld
nameserver nnnn.nnnn.nnnn.nnnn

where nnnn… is the IP number of your box (provided it runs DNS) or of the DNS server of your provider otherwise.

You could also show the result of

dig @localhost www.google.com

to make sure that your local DNS is running fine.

This one seems to need bug report. With host(1) doing DNS lookup, it looks like problem must be glibc/nscd related.

Have you got IPv6 disabled? I have done that.

Seen arguments of ppl with C library maintainer (Ullrich Drepper) about this line in hosts.

special IPv6 addresses

::1 localhost ipv6-localhost ipv6-loopback

If that’s problem then s/localhost/&-ipv6/ so only localhost is 127.0.0.1 would solve it.

I’m running a dnsmasq & pdns-recursor based routing with 11.2, providing same services as you are, without anything odd on the gateway host.

  • added *** to ip adderss to hide mine :slight_smile:

dracula:~ # cat /etc/resolv.conf | sed -e "/^#/d"
search hsd1.ca.comcast.net.
dracula:~ # /sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 00:50:45:5C:35:84
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::250:45ff:fe5c:3584/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1001607 errors:0 dropped:0 overruns:0 frame:0
          TX packets:940506 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:252470933 (240.7 Mb)  TX bytes:308485943 (294.1 Mb)
          Interrupt:27

eth1      Link encap:Ethernet  HWaddr 00:50:45:5C:35:85
          inet addr:76.126.***.**  Bcast:255.255.255.255  Mask:255.255.248.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2141707 errors:67 dropped:0 overruns:0 frame:17
          TX packets:935656 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:387008110 (369.0 Mb)  TX bytes:248211808 (236.7 Mb)
          Interrupt:27

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:106 errors:0 dropped:0 overruns:0 frame:0
          TX packets:106 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:13724 (13.4 Kb)  TX bytes:13724 (13.4 Kb)

dracula:~ # /sbin/route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
76.126.***.0    0.0.0.0         255.255.248.0   U     0      0        0 eth1
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         76.126.***.1    0.0.0.0         UG    0      0        0 eth1
dracula:~ # dig @localhost www.google.com

; <<>> DiG 9.6.1-P2 <<>> @localhost www.google.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 22786
;; flags: qr rd ra; QUERY: 1, ANSWER: 7, AUTHORITY: 13, ADDITIONAL: 8

;; QUESTION SECTION:
;www.google.com.                        IN      A

;; ANSWER SECTION:
www.google.com.         154208  IN      CNAME   www.l.google.com.
www.l.google.com.       49      IN      A       74.125.19.104
www.l.google.com.       49      IN      A       74.125.19.105
www.l.google.com.       49      IN      A       74.125.19.106
www.l.google.com.       49      IN      A       74.125.19.147
www.l.google.com.       49      IN      A       74.125.19.99
www.l.google.com.       49      IN      A       74.125.19.103

;; AUTHORITY SECTION:
.                       169298  IN      NS      a.root-servers.net.
.                       169298  IN      NS      j.root-servers.net.
.                       169298  IN      NS      i.root-servers.net.
.                       169298  IN      NS      d.root-servers.net.
.                       169298  IN      NS      g.root-servers.net.
.                       169298  IN      NS      k.root-servers.net.
.                       169298  IN      NS      h.root-servers.net.
.                       169298  IN      NS      m.root-servers.net.
.                       169298  IN      NS      l.root-servers.net.
.                       169298  IN      NS      c.root-servers.net.
.                       169298  IN      NS      e.root-servers.net.
.                       169298  IN      NS      f.root-servers.net.
.                       169298  IN      NS      b.root-servers.net.

;; ADDITIONAL SECTION:
a.root-servers.net.     93657   IN      A       198.41.0.4
a.root-servers.net.     95120   IN      AAAA    2001:503:ba3e::2:30
b.root-servers.net.     94922   IN      A       192.228.79.201
c.root-servers.net.     101194  IN      A       192.33.4.12
d.root-servers.net.     97188   IN      A       128.8.10.90
e.root-servers.net.     96469   IN      A       192.203.230.10
f.root-servers.net.     93990   IN      A       192.5.5.241
f.root-servers.net.     93956   IN      AAAA    2001:500:2f::f

;; Query time: 14 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sat Dec  5 14:09:14 2009
;; MSG SIZE  rcvd: 511

im not sure what network manager i use i just use yast

as for the disabling of ip v6 i turned it off in the yast networking devices and restarted the server but i dont think it was disabled as i still have an ipv6 for my internal and dhcp still looks for a v6 address as well

thank you guys for all the help i was completely lost on what was wrong

ok i got it i added the name server in /etc/reslov.conf and its working now thank you again for all your help :slight_smile: