Live KDE 12.2 boots to desktop but USB kbd and mouse are dead

I am running OpenSUSE 12.1 KDE 4.8 on a 2004 AMD Opeteron box. 12.1 works okay on this machine (but see disclaimer below).

I downloaded and burned KDE Live CD for OpenSUSE 12.2.

KDE Live boots to KDE workspace screen with no errors, but that’s as far as it goes. Mouse frozen. Keyboard navigation not working.

Back story and disclaimer. But not really relevant to the Live KDE CD issue.

I had a similar kbd/mouse problem with a particular kernel on 11.2(?) two years ago. Due to this I keep multiple kernels and my grub menu is long. I back boot when this problem crops up.

I did a network upgrade from 12.1 to 12.2. Before burning the KDE Live CD. The on-line upgrade to 12.2 also failed in due to dead kbd/mouse. Actually, GRUB kbd/mouse worked, but “emergency console” for fsck was dead. This is not an X problem. It is a kernel or initrd problem with the hardware.

I am currently down booting to 12.1 kernel with lots of 12.2 software loaded. This works, but maintenance is (will be) a nightmare.

– Dan Connelly

And your question is?

You are being sarcastic, perhaps!

First question: Are other people seeing this problem? It does not show up in bugzilla. If I am not an isolated case, I will work on filing a bug report.

Another question, of course, is what changed between 12.1 and 12.2 that kills USB keyboard and mouse? (Same problem happened for me going from 11.1 to 11.2. Dot 2’s no good? But seriously, did hardware compatibility change intentionally going from 12.1 to 12.2?)

The main question is: When might there be a “stable” OpenSUSE 12.2 (or 12.3) that will work with my USB kbd and mouse, one that will upgrade my 12.1 system?

As mentioned in my post, my 12.1 is really a failed on-line 12.2 upgrade. It runs, but Yast is not happy seeing 12.2 code over a 12.1 repo. I would like to repair this, up or down, preferably up.

I’ll try out any stable 12.2 kernel that gets released, but not Kernel of the Day unless someone can assure me that KoD has addressed this sort of problem.

Perhaps I need to skip 12.2 and wait for 12.3, just as I had to skip over 11.2 a few years ago. In which case, I will need to do a full 12.1 re-install so that my system does not appear so corrupted while I am waiting for new “stable” code.

– Dan Connelly

I’ll try out any stable 12.2 kernel that gets released, but not Kernel of the Day unless someone can assure me that KoD has addressed this sort of problem.

If you really think it is a kernel thing, I would suggest you compile a recent kernel with SAKC. I had a similar problem (no mouse or keyboard) with Kernel 3.5.0 from tumbleweed (but with no other version), which got fixed with a subsequent update and I had to use a self compiled kernel for a couple of weeks (I also do this now for other reasons). I would previously add multikernel support to yast.

You did not mention the BIOS so I have no no idea if it relevant, but I do note that I have a desktop where the USB keyboard and mouse only works if I force it to ‘legacy mode’ in the BIOS.

I also note if I put a mobile phone next to a wireless mouse or wireless keyboard, or next to the transmitter on the PC for the wireless mouse or keyboard, they do not work well.



on the assumption you have a pc

have you tried plugging into a lower numbered usb port or
the ps2 i/f (if you have one)?

normally on my machine the keyboard and mouse are connected via a front
mounted usb 2.0 port (its much more responsive). this port is not loaded until late in the initialisation
process and hence

  • the bios set-up can never be entered with this set-up
  • its not available after some sw and kernel updates

in these instances, usually, a usb 1.0 port can used

best of luck

I had that problem at one time. The system would run for a while, then stop responding to mouse clicks.

On the same computer, Acronis True Image (backup software), when booted from CD, did not respond to mouse.

When I ran linux with “nolapic” on the kernel line, it worked. When I rebuilt the Acronis CD, and told it to use “noapic” as a kernel parameter, that worked too (the Acronis CD uses linux).

With recent versions of linux, I have not had this problem. The kernel recognizes a problem with apic support, and does the right thing to handle it even without a kernel parameter.

This might not be your problem. But it is easy enough to boot the live CD and type in “noapic” (without the quotes) on the kernel param line during boot, to see whether that helps.

The X86_64 CD works! X86 (32-bit) does not.

My installed 12.1 is 32-bit. That boots fine. Works fine. No 32-bit 12.2 that I have tried works.

I should have mentioned in my original post that although I once ran OpenSUSE 10.3 64-bit on this AMD Opteron box, after a year or two I **switched to the 32-bit **architecture due to hardware issues. This was quite a while ago, maybe for the very same hardware issues I cited here. Maybe not. I don’t recall the details.

I got no where in 12.2 upgrades on 32-bit kernels (tried 4 different ones, including SAKC builds of stable releases). All had dead kbd/mouse problem on boot, although GRUB boot loader (prior to kernel loading) had no trouble with kbd. This is same problem I posted concerning the 32-bit CD.

The trouble started when I attempted “zypper dup” on-line upgrade to 12.2. This was also 32-bit, of course. Didn’t work.

I was in the shower when I realized I should try 64-bit architecture again for the 12.2 hardware problem.

64-bit CD for 12.2 KDE Live works on my Opteron and its AMD chip-set. That great news. but I am slightly hesitant to proceed to a full 64-bit install.

DOES ANYONE KNOW, since I have kept multiple 32-bit kernels, will the 64-bit 12.2 install keep these kernels and allow me to have multi-architecture boots. (So I can retreat to 12.1 32-bit if the 64-bit install does not go well.) Probably not since drivers, modules and applications will all migrate to 64-bit. Installing from the 64-bit CD appears to be an all-or-nothing transition. (Where “all” means getting at least a console login with no keyboard issues.)
– Dan Connelly

I don’t think it is wise to do an upgrade from 32-64 bit they are just different enough I’d worry about it. Do a clean new install yes keep you home yes put IMO don’t do a upgrade it will just lead to grief.

Posting now to complete this thread.

Yes, I did a fresh install of OpenSUSE 12.2 x86_64 on my old Sun Opteron workstation. It was not straight-forword. Default kernel still has dead keyboard and mouse. Desktop kernel works fine.

Details (to bore you):

  1. The Live CD 32 vs. 64 issue turned out to be red herring. Both 32-bit and 64-bit CDs have functioning keyboard and mouse in “No ACPI” boot up (F4).
  2. My BIOS is ancient. Oracle wants me to pay twice the value of the old workstation for “support” on a BIOS upgrade to get ACPI. I will not pay.
  3. As stated at beginning of this thread, 64-bit Live CD did boot up to Linux when I first tried it. Did not need F4 Safe Mode on first few boots.
  4. Later, this same CD did not boot to Linux unless I gave it F4->No ACPI. Was getting kernel panics. Some new BIOS setting must have wrecked it.
  5. Did full 64-bit install once CD booted to Linux. In order to get acpi-off for boot loader, I switched to basic Grub during install (ignorance of grub2)
  6. After install, Keyboard and Mouse worked with Desktop kernel 3.4.11-2.16. But Nouveau driver for NVidia GeForce 8400 GS left me with lo-res screen.
  7. Installed NVidia driver. Set kernel options on default and desktop, with/without failsafe, to: “showopts acpi=off noresume nomodeset splash=silent quiet”
  8. As stated above, my new 64-bit OpenSUSE 12.2 desktop runs beautifully. Much faster than the old 32-bit OpenSUSE 12.1 I had been running.
  9. However, default boot (using these kernel options) has non-responsive keyboard on console boot. On desktop, both kbd and mouse are dead.
  10. I believe there is a USB problem in the default kernel, but I am too lazy (and stressed) to chase it down. Might be the ACPI issue, despite acpi=off. Dunno.

Do you have Alcor USB hub by any chance?

Nope. AMD-8111 Hypertransport I/O Hub

BTW, when I wrote “desktop” in that snippet you quoted, I mean KDE desktop running under default kernel. KDE desktop running under desktop kernel responds normally to keyboard and mouse. This is not an X issue.

Hardware info for “USB Hub EHCI Host Controller” lists model=“Linux 3.4.11-2.16-desktop ehci_hcd” which is a kernel module loaded by default. Apparently it simulates physical USB Hub. Perhaps this module is configured differently on “default” kernel as opposed to “desktop” kernel

Okay, this is interesting.

/lib/modules/3.4.11-2.16-desktop/modules.builtin lists both ehci_hcd.ko and ohci_hcd.ko.

But /lib/modules/3.4.11-2.16-default/modules.builtin does not have either module built in. Apparently the default kernel is (intentionally ??) de-featured of built-ins for some host controller hardware.

I suppose I should figure out the kernel option for force loading of the missing modules. But I probably won’t bother.

This has been this way for years … could you be more specific why it matters?

I had difficulty transitioning from 12.1 to 12.2 on an old Sun workstation, AMD Opteron. Tried 32-bit online update. Tried vanilla kernels. Tried 32-bit Live CD. Tried 64-bit Live CD.

All were busted. Most failed with dead keyboard for console. Both keyboard and mouse were dead for KDE. Both keyboard and mouse are USB devices on AMD 8111 controller.

Despite title on this thread, its NOT just that the Live CD is busted. Its not an X problem either.

Finally (with acpi=off, which solved random kernel panics), I installed 64-bit KDE OpenSUSE 12.2 from Live CD. Full install to root partition.

Now, Desktop kernel works great. Thank you very much. Shows ehci_hcd kernel module in use for USB hubs,

Default kernel STILL has dead keyboard and dead mouse. Need to cold boot from default kernel. No log information after the re-boot. I am merely guessing that USB controller modules, which are handled differently in default and desktop kernel setups, and are needed on boot for my hardware, may be the reason desktop kernel works and default kernel does not.

OpenSUSE 11.3 had similar problems with keyboard and mouse on this box. As you say “been this way for years”. Some kernel updates just don’t work for me. Why? Why is USB setup different on two kernels? Apparently module.d has config to provide ehci support in either case. Not sure why it is done this way. Not sure it works on my hardware.

This matters (other than curiosity) because I now fear that future kernel updates and future distributions may be similarly painful. I need recovery and workaround strategy in case both kernels have the failure (as was the case for 11.3, as I recall it.)

Under module.d, 00-system.conf suggests that there may be a module dependency issue. OpenSUSE hints for mkinitrd to cover this. Might not work in my situation. ???

First: I did not mean to appear sarcastic, just didn’t get what you wanted.
Second: if the hint is there, I’d follow it.
Third: I’m by no means an expert on matters like this, but it seems that the kernel sources basically does support your hardware - kernel-desktop works -, but the compiled kernels don’t. Is compiling your own kernel an option to be considered? @jmcdaniels has some nice scripts (see the Articles section) that might solve your issues.