LIve Disk, NV driver and the black screen


First time poster and long time user :slight_smile:

I was wondering if anyone know of any issues with the “nv” driver (not the closed binary) and the installer?

I ask because when I tried to boot off the live-GNOME disk I seem to get nothing but black screen when the it tries to start X.

If I boot into text mode and change my driver to vesa, I can start x and start the installation but toward the end it black screens on me and just hangs!

I had no issues installing SUSE 11.0 with my current hardware

FYI, I’m using a 8800GTS card if that might help.


I had the same issue with the LiveCD-KDE4 and a similar graphics card (8800GT).

My monitor would go out of sync regardless of whether I booted up the CD in text or GUI or even failsafe.

This is what I did to bypass the nv driver issue, guess you could give it a try.

  1. Boot at Init level 3. At the Launch Screen, type in ‘3’ (without quotes) in the Boot Options area.

  2. Log in as root once you get the terminal.

  3. Start SaX in safe mode ‘sax2 -r -m 0=vesa’ (I think this is the only step you’re missing, forcing X to redetect your 8800GTS)

  4. Change your config if necessary, though I find that once you get here it’s all plain sailing.

  5. Logout and fire up X with ‘startx’ and you should see the splash screen.

Good luck! :wink:


Thanks. I was sure I couldn’t be the only one seeing this behavior lol. I will give the sax construct a shot when I get home. Since my power light didn’t go amber I didn’t even think of a monitor sync issue.


Well the sax2 reconfig helped me get X up to run the installer, however are the install completed and I rebooted, my black screen reappeared. I tired to hit run level 3 go I could get to a command line so I could check my x config but was present with black after most services started. Even run level 1 had the same issue :(.

It would be so bad but once my screen goes black I can’t hit a virtual console or anything to check logs. Oddly enough the disk works fine in my laptop which also has a Nvidia card. It must be a quark with this 8800GTS.

Once again, looking for suggestion since I can’t evaluate logs.

When you ran configured X, did you select the right resolution and frequency for your screen? Once, when I forgot to do this (after umpteenth install to fix various other problems), it saved the wrong settings and gave me the blank screen upon install reboot.

If you’re looking to dig at your log files, you can fire up from the Live CD and get into them from there.

Sorry that I can’t be of more help, I’m completely new to Linux and what I passed on was just what I found here that worked for me.

Go through the rest of the Install/Boot/Login forum, there are variations of the same problem and many have been rectified. I tried some, didn’t work for me but they might work for you.

[Confession/] I went back to Ubuntu, as I had too many conflicts in openSUSE. One issue after another kept cropping up, nVidia drivers wouldn’t stick, regularly losing 3D after reboots, YasT would run really slow, would regularly lock-up on me, Windows partitions refused to mount, etc. My rig just didn’t like openSUSE and I didn’t have the technical wherewithal to troubleshoot everything [/confession]

I believe I might be in the same boat this time around. I just don’t have resolve to brute force my selected software of choice when I know of others that work as expected form the get go.

Its a shame too because 11.0 fully worked as expected and I was very much excited for this release!

Oddly enough my laptop can run the live cd but now, due to my desktop experience, I’m wondering if I want to take that gamble.