live cd trouble

Hi! I hope someone in the forum may help me with this issue. I have been using opensuse since the 9.1 version on another computer. Now I’ve just bought my self a new laptop, asus x5500dp with win 8. The first thing I did was to download an opensuse live cd. The live cd stops at boot at the following line: “started hostname service”. I have also tried with several other live cd distribution, but the only one that actually boots to the desktop is Knoppix, but only if I add “acpi=force irqpoll” to the boot parameters, and it starts with no wifi. Right now Im stuck in windows 8, and would really appreciate some help

After some more testing I found the answer to be to include “nomodeset” before booting. But when I try to install it boots back to windows after reboot.

There are some versions of UEFI that just won’t allow you to boot to another OS other then Windows.

There is a trick to work around this entailing a mod to the /boot/windows files. Best to look it up here since I have not had that problem and only read about it here.

After some thinking I started believing it may have something with legacy/uefi mode. So I tride booting in uefi mode and receives the following error: “failed to find mbr identifier”.

Think that is because you tried to install in MBR mode.

leave in efi mode be sure any fastboot is off


at the partitioning section be sure that grub-efi is selected and be sure that secure boot is ticked.

If it still insists to boot to windows let us know there is a solution but I can’t find it right now maybe some one else will jump in

Thanks for your advice, and what you explains seems pretty obvious. I’ll give it a try :slight_smile:

I really hate this uefi thing. When I first tried to boot my usb live stick in uefi, the screen just went blank. I then tried once more with “rufus” to make a bootable usb, it works just fine in “legacy” mode, but in uefi mode it gives me this eror: vfs: cannot open root device

Right now I dont have a clue of what to do to get opensuse 13.1 installed.

Hi !

As far as I know, for several versions there has been a problem to boot openSUSE from a live CD on UEFI/secure boot systems.

Try to boot/install from the openSUSE 64bit installer DVD !

Good luck !

On 2014-01-27 21:16, bjarte k wrote:
> I really hate this uefi thing. When I first tried to boot my usb live
> stick in uefi, the screen just went blank. I then tried once more with
> “rufus” to make a bootable usb,

AFAIK, “rufus” or any such thing destroys the openSUSE install media.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

I’ve tried to burn the live-cd on a dvd with the same result. But I guess the next logical thing is to try the full install dvd, and see if I have more luck with that. Thanks for advices.

Im getting closer. I have now installed the system succesfully, and Grub gives me alternative to boot to opensuse 13.1 or to boot to windows. At first try it booted fine into my new opensuse desktop, but after a reboot it stops at a “blank screen” just after it has started X. Any tips on what to do?

Go to advanced and select rescue mode

I’ve already thought of that, but rescue mode doesnt help me either. Im not even sure what rescue mode is supposed to do, it just boots untill it starts network and then stops… From there Im able to hit ctrl alt f2 and login, but Im really lost here… Should I try to download the fglrx drivers?

Hi !

Do you mean a reboot during installation, or a reboot after installation ?

What did you do between these reboots ?
Did you install something ?

Good luck

It worked fine both the reboot during installation, and the first reboot after installation.

I think Ill try to reinstall and see if my luck changes.

After a new reinstall using the full dvd install, the system boots just fine. My only problem now is that my wireless don’t work any good. It works for about 1 minute before it disconnects and network manager doesnt have my network listed anymore. The loaded driver for my ralink is rt2800pci.