Live CD problems

Hiya everyone.

Well, I am trying to get Suse 11.0 to run on my PC. Though after the bootscreen it loads all the components and then It gives me a blank, black screen, in which i cannot do anything.

I am suspecting that it is a problem with our Nvidia Graphics card. It is a Nvidia GeForce 6150SE nForce 430.

Any help will be apprecated.

I typically check a liveCD, and if it does not work I just throw it out and spend no more time on it. And even if it does work, I rarely install from a liveCD. I run live CDs more for curiousity, than any seriousness. And I suspect there are many like me.

Hence many of us are reluctant to help liveCD users, as we speculate others are like ourselves, and there is not much point spending too much time with a user who will never do a permanent install, and will throw out the cd in a few days, or at the 2nd glitch (just like we would).

Anyway, if it were me who obtained that problem (with an openSUSE cd) before I chucked it out, I would press <CTRL><ALT><F2> or <CTRL><ALT><Backspace (twice) and try to log on to an ascii text mode. Or I would simply boot the LiveCD direct to an ascii text mode (run level 3) and log in. … After logging in I would then type “su” to get root permissions, and try to configure my graphic card with sax2. Possible options with a nvidia card include:
su -c ‘sax2 -p’
(the determine if one’s card is chip 0 or chip1). If chip 0, then:su -c sax2orsu -c 'sax2 -r -m 0=nvidia’orsu -c ‘sax2 -r -m 0=vesa’

and if one of those appeared to have worked, typestartx
To shutdown from a text log in, simply type: su -c ‘shutdown -h now’