Live 12.1 KDE CD boots to command line

I am posting from the computer that I wish to upgrade (currently running openSUSE 11.1) so the hardware should be fine. I checked the CD. When booting from the live CD, it boots to the command line with the following message:

Welcome to openSUSE 12.1 "Asparagus" - Kernel 3.1.0-1.2default (Hy1).
linux login:

I spent about a half hour here searching to see if someone else had the same issue and didn’t see it. I tried changing the video mode using F3 to see if a video driver was the problem and had the same result. I would appreciate suggestions.

First of all not sure what the problem is with the CD but you can not upgrade from 11.1 to 12.1 This is simply not supported in anyway, there are far too many differences. Also the CD does not offer a upgrade option you can only do a new install from a CD. That said did you try entering nomodeset at the boot? Also what video card/chip do you have?

Thank you for the quick reply. I am not attempting an upgrade. I would like to see the system run as a live CD and then do a clean install (using my old /home directory) after I confirm that I have no issues (or at least minimal issues). The problem is, the system won’t even run as a live distribution.

I will try the nomodeset command, but don’t know where to enter it–on the boot options line of the opening screen?

The video card is an ATI Radeon 9500 Pro. The processor is an Athlon XP 2500+. The Asus motherboard uses a VIA chipset, but I don’t know the number.

“on the boot options line of the opening screen?”

Yes

I tried the nomodeset command and got a little farther. The system starts to load and then stalls with the screen below:

http://img845.imageshack.us/img845/6926/opensuse121.jpg

For the record, I tried the CD on another computer and it boots into the live desktop without issue. I am starting to suspect that this computer may have to stay with version 11.1. :frowning:

Hi,
I have the same problem (ati radeon 9500, amd athlon 2600+ and asus a7n8x mainboard; I was running openSUSE 11.2 before). But I did not tried the live cd first (never had this kind of problem before and I am using openSUSE for years).

I tried to install from DVD: first of all the installer was graphical. Then after installing all the packages, the installer changed to text mode (sorry, i forgot the text of the error message). So I completed the setup in text mode because I thought “well maybe this will change after running an update”. But it did not…

After this, I tried the kde live cd and it boots into the console (like harold01 said).

I also do not know how to proceed to solve this problem :(.

I feel your pain. I understand that the ATI Radeon 9500 is not very current, but it was hugely popular years ago, and I suspect a substantial number of computers are still using it.

I had a similar issue (I’m not currently at home, so I don’t know exactly what my hardware is). I have installed/reinstalled 12.1 three times now, and my boot goes to text. I am asked for root password to login, which gets me a command prompt. I have not tried the CD yet.

  1. Somewhat similar. Old computer works fine on OpenSUSE 11.4 , and on live distros Knoppix latest version, Ubuntu 11.10 and on small systems as Puppy.
  2. running LIVE DISC OpenSUSE 12.1 KDE or Gnome does not load, or rather crashes at home screen on any mouse action or command. These discs work on more modern laptop computers.
  3. Tried some smaller 12.1 versions from Suse Studio. Some get to command line like yourself. some work but extremely slowly. I suspect a Graphics card problem (Radion old circa 2002 graphics) or insufficient RAM (only 512MB).
  4. any consistent report or help would be helpful. I do not want to change distros while keeping this desktop machine working.

Thanks, Eionmac. I actually found the problem: I was configuring /etc/fstab during installation, while customizing my partition setup. I solved the problem by leaving /etc/fstab more or less alone, then editing it post-installation. Seems to be working just fine now.

Does the safe settings boot work ?

Does the safe settings boot work ? (I can’t recall exactly - but I think it is an F5 key option on the liveCD).

Sorry,
I am currently away on a business trip. I did not tried it at weekend but I will try it when I am back again.