literally ODD problem - network services don't work every second boot


I have an OpenSuSE 11.1 in vmWare ESX and every other boot I can’t access any running network services (ssh, webmin, qmail, mysql, …) from outside. I just need to login, reboot and voila - network services are working.

I gradually updated to 11.2 and 11.3 by following the wiki with success but this problem remained. So I reverted to snapshot of 11.1 and now I would like to identify and solve the problem here first.

I also looked at /var/log/messages /var/log/boot.msg /var/log/lastlog but can’t find anything usefull. I will now compare those files from the working and non-working boot but meanwhile someone already has an idea or experience what could be wrong?

So how do you know it is every ODD time that it does not work? Perhaps it is every EVEN time it does not work, that would still be kind of ODD I guess. lol!

Well, now when it works it works and I don’t know of a ODD - EVEN bug in networking. So can we say that it is the Virtual openSUSE 11.1 that is having the ODD / EVEN network issues and not the Host system?

What are you using as the Host system for the VM? openSUSE again? The logs you are looking at, are these in the VM or the Host?

I have a script file that allows you to look at several of your log files. Check it out in the thread:

S.L.A.V.E. - SuSE Logfile Automated Viewer Engine - Version 2.00

Thank You,


the host is running VMware ESXi and there is another OpenSuSE, 11.0. and it doesn’t have this problem so I am not sure it’s vmware related. But it may be. The logs are from the VM and as it is ESXi there is not much to check on the host (no ssh access, just Virtual Infrastructre Client GUI). I also copied the virtual disk, created a new VM from it and it has the same problem.

I tried your script but it probaby doesn’t work on 11.1 - when I press any choice the screen just refreshes itself on the display.

No, I have not tried slave on openSUSE 11.1 but it does work on 11.2 & 11.3, but not sure what would be different 11.1. Sorry about that.

Thank You,


Did you solve that issue? We have something similiar with one SLES11 SP1 … every now and then after reboote we receive “the lan is offline” for eth0 device. Everything works fine after doing another reboot …

Regards, Stefan