Lite on DVD not recognized by K3B


I have had CDROM in my openSuse 10.3 machine and I put new Lite on DVD. When I Start K3B it says that there is no recording device.
How to get K3B see my new DVD?



Is it just k3b that you have issue with. Is it working otherwise?


Yes, it opens tray normally, I can put DVD inside. So, I guess device/hardware is OK.
I Suspect that there is issue with K3B since it says also that I cananot do anything with mp3 although such a message was not appearing when Ihave had my CDRom. Thus, it settings are somehow lost and it behaves like there is no previous settings.
When I tried to Add device and put that device is /dev/dvd it said that tere is no dvd device. I guess I have to create it. How to do so?
Do you need more information?


What I mean is:

If you insert a data disk, can you read it in the file browser?

No, I can’t.

I will check some wires or so, but I do not think that wires/cables are an issue.



In a terminal go su


does it show in the output? It may be a long list.

The issue is solved by disconnecting CDROM that was connected to the same IDE channel.
DVD is recognized well now.
Obviously, on some motherboards DVD and CDROM cannot be on teh same channel since they take resources from each other.
I hope this will help to someone.


Nice. Thanks for letting us know how it was resolved.

Or maybe both got set to master or both got set to slave. Obviously that won’t work. Anyway a DVD drive will handle CDs too so no loss.

They were properly ordered, CDROM was master and DVD was slave, but disconnection of CDROM released DVD.
Actually, I realized that DVD tray works fine , but when I put CD or DVD inside it does not attempt to read it. I suspected that it actually attempts but it was immediately stopped due to unability to use resources as needed.

Thanks on support guys/girls :slight_smile: