linuxrc: Boot Installed System

I notice that the function “Boot Installed System” just does not work in linuxrc for 11.4. I recall using it on 11.1, and it worked. What I get when I select the partition where I have my filesystem is simple: blinking cursor.

That’s quite inconvenient for booting system with broken GRUB.

\begin{Digression I}
For those wondering how to get into linuxrc:

In my case, the network installer of 11.4 (booting from a USB stick).

I boot, select “linux”… We are in linuxrc. It asks me “Insert CD1”. Ok CDs… Press back. Then you have a menu.

If you have the DVD, start the install, then when you get the License Agreement screen, click abort, and it takes you to linuxrc (I wonder if there is a more straightforward way from the boot screen).
\end{Digression I}

\begin{Digression II}
I use the network installer since, with linuxrc, it’s easy to start the openSUSE installer from an .iso on a hard drive., which is then very fast (no need to burn a thing).
\end{Digression II}

Then, I need to find another satisfactory recipe for emergency boot. I tried something from *openSUSE 11.3 Start-Up * Guide: (applied on 11.3 and 11.4, without success)

boot from recovery console

mount /dev/sda6 /mnt
mount --bind /dev /mnt/dev
chroot /mnt
mount /proc
mount /sys
mount -a


grub --batch < /etc/grub.conf
umount -a

Anything else should be done from recovery console to reinstall our grub? Or is this rock-bottom stuff supposed to work just fine?

If I have a printed copy of menu.lst in front of me and a bootable usb or DVD installer, can I, from the boot screen type menu.lst stuff and get in my system from there?