Linux Wireless is always a pain: system freeze with Atheros

I’m now using SuSE for about 3 years also as my Desktop system as well as on my Laptops, and all the time it comes to wireless stuff it is a terrible pain!
My first bad experience was with an older Laptop which had a buildin prism wireless card: SuSE detected this card wrongly, and assigned the prism54 driver for it which did nothing more than fill the logs with ‘bad interrupt’ and such thinks - after I tried each and every firmware I could find I finally gave up, and switched over to ndiswrapper which worked almost stable. One year later I found the p54 driver appearing with the OpenSuSE downloads, and this was now finally the right driver which works 100%.
When I got a new access point with SuperG 108Mbit I tried a 108MBit PCMCIA Card with Atheros-Chip - but only to find that the system got freezed every now and then so that this was absolutely not usable, and I stayed with the build-in 54Mbit prism card…
Meanwhile I have a 300Mbit access point, and I was brave enough to try a 300MBit PCI card in my desktop computer: all I could archive was total system freeze once I tried to connect!!!
This is really a horror, and unfortunately I see this is not only a SuSE problem, but a very known issue which affects all systems which try to use the ath9k driver, f.e. see here:
[all variants] ath9k lockup on 8.10 and 9.04 on AMD - Ubuntu Forums](
then found this:
Bug 12110 – ath9k causes computer to hang after long data transmissions
which suggest that I have to look for a later kernel than the which I got via update, argh!
Wireless and Linux is a pain, really!