Linux SMB shares not appearing in Windows Workgroup

As per the screenshot below, I have created several shares in /etc/samba/smb.conf which are browseable when using a Windows machine if I enter the IP address of the computer into the address bar, but they don’t show “by default” in the workgroup list:-

http://img257.imageshack.us/img257/2528/badgergrouple7.th.jpg](http://img257.imageshack.us/my.php?image=badgergrouple7.jpg)

You see the left-pane shows the computers “Media Server” and “Data Server”, but the right-pane only shows the two Windows machines “Download Server” and “Virtual XP”.

I can’t for the life of me recall where I saw or read about the “fix” which would make all the machines show in both panes (without having to browse to the SMB shares first).

Can anyone offer any help please?

edit:-
Example smb.conf from one of the linux machines:-


# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2008-06-06
[global]
        printing = cups
        printcap name = cups
        cups options = raw
        map to guest = Bad User
        include = /etc/samba/dhcp.conf
        logon path = \\%L\profiles\.msprofile
        logon home = \\%L\%U\.9xprofile
        logon drive = P:
        usershare allow guests = Yes
        netbios name = bgrsvr-y
        workgroup = BADGERGROUP
        server string = "Data Server"

[to-sort]
        comment = items-to-sort
        path = /home/badger_fruit/data/to-sort
        guest ok = yes
        read only = no
        force user = badger_fruit


got it; thanks to a guide written (here → Script To Quickly Diagnose Samba Workgroup Configuration Problems in Suse openSUSE 10 and 11)
all i needed to do was add the line “name resolve order = bcast host lmhosts wins” in the “Global” section, restart smb and after a few short moments, the Linux machines appeared in the Windows workgroup

http://img511.imageshack.us/img511/9444/snapshot2wu6.th.png](http://img511.imageshack.us/my.php?image=snapshot2wu6.png)

Glad the script works.

Thanks for the copy of report.txt. Seems the only really consequential stuff was the “name resolve order”. The other cautions were firewall-related, which you could tweak if you wanted to turn the firewall on.

no problem, you helped with the script, i helped with the results.txt! it’s a great script, i love the fact after it’s run the instructions on how to make the change are included in the .txt file :slight_smile:

Keep up the GREAT work and MERRY CHRISTMAS TO ONE AND ALL!!

OK, now this is wierd!
I had to reboot both my Linux servers to put in extra hardware last night, when they came back online, they were again missing from the Badgergroup view in Windows explorer!!

Nothing had changed on the smb.conf (and I mean NOTHING!)
I also notice now if I go into Yast > Network Services > Samba Server, I don’t have the option for “Identification” or “Startup”, it just presents me with the list of shares and allows the usual, Add, Edit or Deletion of them.

Any ideas please?
It’s not an end of world thing but it sure is strange!

Your firewall is set to block Samba, is it switched off? That will prevent the shares from being viewed from windows.

And what is the Desktop Environment and the SuSE Release?

Regarding the missing tabs in “samba Server” in Yast: I’ve never seen that or heard of it. Is that the same for both Linux servers?