Linux newbie looking for help with Toshiba Satellite U400

First of all: Hi! since this is my first post on the forum.

I recently installed OpenSuse 11.1 (kernel Linux x86_64) on a Toshiba Satellite U400 and generally it’s working fine, but I still have some problems:

  1. is there a way to show some sort of message or icon when I press one of the Fn+FX combinations?

  2. is there a way to get the extra hotkeys (play, pause etc.) to work? I have fnfx installed but I don’t know how to make it run, because the documentation for it is not available anymore.
    I also tried using ktoshiba, but when I run it I get the message:

costi@linux-bxi5:~> ktoshiba
getInstance(pad.cpp:16)  --- waiting for lock...
Pad(pad.cpp:45)  --- created singleton
registerParameters(pad.cpp:489)  --- registration done!
init(pad.cpp:494)        --- this version of libsynaptics supports the following driver versions:
init(pad.cpp:499)        ---  --- 0.14.4
init(pad.cpp:499)        ---  --- 0.14.5
init(pad.cpp:499)        ---  --- 0.14.6
init(pad.cpp:501)        --- initializing fitting driver segment...
detectDriverVersion(pad.cpp:150)         --- detecting driver version...
driverStr(pad.cpp:193)   --- driverStr
intVerToStrVer(pad.cpp:96)       --- intVerToStrVer
detectDriverVersion(pad.cpp:180)         --- detected driver version 0.15.2
driverVersion(pad.cpp:115)       --- driverVersion
driverVersion(pad.cpp:115)       --- driverVersion
init(pad.cpp:545)        --- driver is too recent, please downgrade driver or updatelibsynaptics!
getInstance(pad.cpp:20)  --- ...unlocking done!
hasDriver(pad.cpp:138)   --- hasDriver
getInstance(pad.cpp:16)  --- waiting for lock...
getInstance(pad.cpp:20)  --- ...unlocking done!
hasDriver(pad.cpp:138)   --- hasDriver
~Pad(pad.cpp:36)         --- detach driver
~Pad(pad.cpp:39)         --- deleted singleton

However, the version of libsynaptic I use is the latest one…

  1. Bluetooth doesn’t work. What what I understand, this is quite a common problem…
    I have installed kdebluetooth and kdebluetooth4 packages, but when I start kbluemon it says that no Bluetooth devices were found and then crashes. How do I solve this?

From what I understood, a solution for number 2 and 3 is patching/compiling the toshiba_acpi module, but I don’t know how to do it (as I said, I’m very new to the linux world).

Can someone help me set stuff up, or point me to an idiot-friendly tutorial on how to do it?

Any help is appreciated.

I have same laptop U400/H00 and same problem.
For multimedia touch keys, when I was using Ubuntu 8.10, it all works; when I use OpenSuse 11.1 with KDE 3.5, some of it works(mute, launch media player which is Amarok), others do not work;
When I use OpenSuse 11.1 with KDE 4.1, all multimedia keys does not work.
There is a package called KToshiba: “KToshiba is an Fn-key monitoring for Toshiba laptops, but it does much more than that.”, I’ve installed it, run it without any effect.