Linux newbie: Jerky desktop problem

Hi, this is my first post on a Linux OS and on these forums lol!

I have just installed openSUSE 11.2 (installation was painless), however when I got on the desktop I noticed that the windows and applications are jerky. I’m assuming that its a driver problem. This is a new PC and I have not tried Windows on it (I intend to switch to openSUSE).

I have chosen KDE for my desktop and have not installed anything else so far. I have searched for my graphics card on the KDE Info Center under PC and it seems to be “Intel 4 Series Chipset Integrated Graphics Controller”.

Do I need to do something to install it? (assuming the problem is the graphics card)?

Thanks in advance :slight_smile:

Regards!
Samuel

Open a terminal and post result of this:

/sbin/lspci -nnk

I am using a Intel 4 on my Lenovo G550. Works a dream.

Yes tell use which video card you have.

Hi :slight_smile:

Thanks for your prompt replies. I have entered the command and the following output was produced>

00:00.0 Host bridge [0600]: Intel Corporation 4 Series Chipset DRAM Controller [8086:2e30] (rev 03)
Subsystem: ASRock Incorporation Device [1849:2e30]
Kernel driver in use: agpgart-intel
00:02.0 VGA compatible controller [0300]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e32] (rev 03)
Subsystem: ASRock Incorporation Device [1849:2e32]
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 01)
Subsystem: ASRock Incorporation Device [1849:3662]
Kernel driver in use: HDA Intel
00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 [8086:27d0] (rev 01)
Kernel driver in use: pcieport-driver
00:1c.1 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 [8086:27d2] (rev 01)
Kernel driver in use: pcieport-driver
00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 [8086:27c8] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27c8]
Kernel driver in use: uhci_hcd
00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 [8086:27c9] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27c9]
Kernel driver in use: uhci_hcd
00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 [8086:27ca] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27ca]
Kernel driver in use: uhci_hcd
00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 [8086:27cb] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27cb]
Kernel driver in use: uhci_hcd
00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller [8086:27cc] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27cc]
Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev e1)

I
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge [8086:27b8] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27b8]
00:1f.1 IDE interface [0101]: Intel Corporation 82801G (ICH7 Family) IDE Controller [8086:27df] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27df]
Kernel driver in use: ata_piix
00:1f.2 IDE interface [0101]: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller [8086:27c0] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27c0]
Kernel driver in use: ata_piix
00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller [8086:27da] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27da]
Kernel driver in use: i801_smbus
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
Subsystem: ASRock Incorporation Device [1849:8136]
Kernel driver in use: r8169

I guess the graphics card is the intel 4 chipset. Is this supported out of the box? Thanks again :slight_smile:

Best regards
Samuel

I have clicked on the My Computer icon on the plasma desktop panel and I have found this.

Display Info
Vendor: Intel Corporation
Model: 4 Series Chipset Integrated Graphics Controller
Driver: Unknown

I guess the driver is the problem. Does anyone know how to install the driver? In the mean time I will see what I can do, if I maange to fix it I will post a reply.

Thanks!

Regards
Samuel

Mine says:

Vendor: Intel Corporation
Model: Mobile 4 Series Chipset Integrated Graphics Controller
Driver: Unknown

Working perfectly:)

I still have a very slow desktop though :frowning:

When I move a window it leaves a trail of windows which disappear after a few seconds and the same happens with Internet pages. Could it be that KDE is not compatible with my system and I have to install openSUSE again with Gnome?

Thanks for your replies! I appreciate it!!

Samuel

Or could it be a hardware related problem? This is a new PC (bought it yesterday). 2GB Ram, 2.6Ghz Core 2 Duo, Intel 4 Integrated Graphics Chipset, 500GB Storage.

The insatllation was very fast… 30 mins from the DVD. Should I try a different desktop environment or openSUSE version?

Thanks again!

/sbin/lspci -nnk

probably the first in the list.

mine is

/sbin/lspci -nnk
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 09)
Subsystem: Lenovo Device [17aa:3a00]
**Kernel driver in use: agpgart-intel
**

Mine is almost the same except for the bold area

00:00.0 Host bridge [0600]: Intel Corporation 4 Series Chipset DRAM Controller [8086:[b]2e30] (rev 03)
Subsystem: ASRock Incorporation Device [1849:2e30]
Kernel driver in use: agpgart-intel

I will continue searching on the forums for a similar problem but most probably I will re-install the system with Gnome… :wink:

It’s a pity as KDE seems nice!

Thanks

/// BREAKING NEWS /// lol!

I restarted the system on recovery mode and the desktop runs very smoothly. Does the recovery mode use a generic driver? If so, how can I set it on the normal mode?

I do not need any special effects or video performance as this pc will mostly be used for work.

Do you mean Failsafe mode?

Yes I meant Failsafe mode. :shame:

When I booted using Failsafe mode the performance of my desktop was much better. It seems that under that mode a VESA driver is used. I’m trying to find a way how to enable it by default.

I have downloaded the Ubuntu live cd to see if this is an openSUSE problem however Ubuntu doesn’t even load up the GUI.

It seems to be a hardware support problem. How can I set the generic VESA driver to take over the current driver that’s causing all these problems?

You don’t want to enable failsafe by default if you can help it.

Try booting with just this argument added to the default boot

acpi=off

Let me show you how. Reboot. At the menu just pause the timer by pressing the down arrow on your keyboard, now move back to select the default boot and use your keyboard to type and the text will appear lower down, like in this picture:
http://public.bay.livefilestore.com/y1pWPR3kmTs_BmYaMBw0XA-O6KdCCzU2yBjwV-WXBCZZyX43x_Ih69a0XADQOQ0YUDeDzptc-ZU-1u49hfvVt3UAg/acpi%20boot%20arg.png

Once have typed that, hit enter. See if it’s better. If not we can try another or add it in so it’s always there if it works.