Linux Newbie having trouble with Nvidia Geforce 9500 GT


After one click install of nvidia drivers, restart machine and it boots into text login instead of kde 4.

My sparkling new hardware : (if it helps)

Intel Core 2 Quad (Q9450)
Nvidia Geforce 9500 GT (Inno 3d)
Asus P5N-D NF750i Socket 775 Motherboard

From first install openSuse knew I had a 9500, but no 3d acceleration. 1-click-install say to use simple-ccsm to turn on effects, but after turning on effects, it doesn’t actaully seem to work, as re-running simple-ccsm shows it still disabled.

From KDE 4 menu, ‘recently installed applications’ shows nvidia app, but when I open it complains that kernel module something somthing is missing (bearing in mind yast install says everything worked fine).

Is my g-card not yet supported by 1-click-install? i didn’t try manual process suggested above, i lost patience after third re-install (also scared off by talk of recompile if i want to upgrade other bits in future), and installed mandriva 2009 instead (free version, with no issues after i used it’s package manager to install nvidia kernal module, pity my sound doesn’t work now :0 ).

i really want openSuse on my system, not mandriva. please help!


I think 1-click-installs are a bit tricky. Personally, I prefer to simply add the videocard repository (in your case that would be the nvidia repository) and let YaST handle the rest. Of course, that way I never have the most recent drivers … but I do have some pretty stable ones;)
As a last resort, you could try running sax2 -r from the console (exit KDE first).

If it worked before, and not now, the odds are this is a simply volume level problem in your mixer.

If all else fails you can start working your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

thanks for the replies thus far.

I shall add the repository and try again, see what happens. But I really did think the problem may be because i DONT have the latest driver. I read a ‘release notes’ somewhere that listed 9500 GT as one of the last cards to be supported (I think because it is a budget card, but a recent addition to nvidia’s product line)

With regard to the sound. It’s the sound in Mandriva, not openSUSE thats not working (what I’m using now). when I get some time I’m going to install openSUSE again. I was hoping Mandriva might just be plug and play, which it hasn’t been. I know the sound in openSUSE is a known issue, and your fix should work (it’s the analog output that was muted on first install), but that hasn’t fixed it in mandriva.

First time i installed openSUSE i got a log file it pointed me too when the setup failed, is their a log file I should look for that I can post in this thread. I know the hardware works, it’s just the configuration I need to get right.

Kind Regards,

umm… trying to have lots of fun. lol

p.s. I not trying to fix the sound in mandriva, thanks for the input, but I only really care about getting openSUSE working. :slight_smile:

p.p.s. advice welcome on what to do if I try re-install and it fails to text login screen again, what to type to get x windows back and all that, or whatever might be usefull. also, not sure if using the ‘failsafe’ boot option is introducing more variables into the mix (whatever that means).

Hi Nnoel,

You mentioned Intel Core 2 Quad (Q9450)earlier, check out your /proc/cpuinfo if it says **ht,lm ** on the flags definitely your system is 64-bit.

Grab the latest nVidia driver as outlined from this posts,

Previously i have trouble with Nvidia Geforce 9500 GT.
Try this post Search Results geforce 9500 « Pitch Over The Rainbow | Weblog