Linux Newbe wants to install Boinc 6.10.17 in SUSE 11.2

I am a complete novice to Linux, just can’t bear the thought of upgrading to Windows 7, so here I am.

I have installed Suse 11.2 OK and am on it now.
I have downloaded from Boinc versions,, and have it sitting in my bin directory, now I am stuck.

The first line of the file reads:

( read l; read l; read l; exec cat ) < “$0” | gunzip | tar xf - && /bin/sh BOINC/ sea.tar BOINC/

Do I paste the line into the Terminal? Something else?

I have been looking for a step-by-step for dummies approach but can’t seem to find it.

I have managed to get the windows version running under wine, but would prefer to have it running natively.

The other problem is how do I get the core client to recognise my five cudas? (4 x GTX 295’s and 1 x GTX 260). In Vista its a pig of a process!

Sorry if I have missed a FAQ or readme here that states the obvious, but I am stuck. :\

What I know about Linux could be written on a smallish postage stamp!

On the amazing side of things, the Windows version running in emmulation mode is only .2 of a second slower than normal, for my climate models, 1.56 s/Time Step (TS) vs. 1.36 s/TS (Vista 64). Admittedly, the CPDN files are 32 bit, but still.

  1. make executable
  2. execute it in a terminal, eg ./
  3. it’ll unpack it and create a director
  4. go in the unpacked directory, open file run_manager and at very top put this in it: #!/bin/bash
  5. save it, make it executable, click on it and… OMG it’s alive :smiley:

CUDA should be recognized if you have the proprietary NV drivers installed

Oh man! Thank you Microchip8!

I have been crunching since the '90s and gave up when I hit opensuse 11.0 because I couldn’t get it to work any longer. Now, I have a reason to leave my pc on all night.

Thanks… I think…? :wink:

It isn’t difficult at all to install BOINC grabbed directly from its site. I just wonder why they don’t just add a startup script for it when you unpack it.

Thanks… I think…? :wink:

You think too much ? :stuck_out_tongue:

OK then how do I make it executable?

I tried typing, in terminal, the following;

david@linux-0lpg:~/BOINC> make executable
make: Nothing to be done for'. make: *** No rule to make target executable’. Stop.
david@linux-0lpg:~/BOINC> make
make: Nothing to be done for `’.

Sorry for the delay in replying but it took me a day just to work out how to install the ‘make’ command.

I also tried running the file and got the following:

david@linux-0lpg:~/BOINC> ./
bash: ./ Permission denied

I just did that because the file looked like it was already an executable.

Anyway I am tring, but am stuck again.

Why do you run make on a shell script? :open_mouth:
Make is only for C/C++/etc programming languages, not for shell scripts

to make it exacutable, either right-click on the script -> properties and set the permissions there or in a console do chmod +x then run it as ./

Why do you run make on a shell script?

Doh. Because I am dumb and took your previous comment literally.

That’s so cool, I’m up and running. Climate models downloading as I type.

OK cpu’s are happy. Now how do I configure the 2 x GTX295’s and GTX260 so Linux recognises them all?

The proprietary NV driver should recognize them all. If it recognizes them, then I assume BOINC will do so too