linux-kernel-headers with a different version

Hi there.

I have OpenSUSE 11.2 with the following kernels installed:

linux-kernel-headers-2.6.31-3.4.noarch
kernel-desktop-2.6.31.12-0.1.1.i586
kernel-source-2.6.31.12-0.1.1.noarch
kernel-default-2.6.31.12-0.1.1.i586

As you can see, linux-kernel-headers do not have the same version as the others. In result, I cannot run VMware Workstation because it is expecting a more recent header’s version.

How can I fix this problem?

Thank you.

Irrelevant, linux-kernel-headers does not contain the headers needed for compiling a kernel module, see “rpm -qi linux-kernel-headers”.

You need “kernel-$flavor-devel” matching the flavor of your running kernel, “uname -r” will tell you.

Hi
No you have the correct version 2.6.31, those don’t change unless
the .31 does…


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
up 8 days 17:48, 2 users, load average: 0.18, 0.20, 0.23
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53

Thank you for your quick reply.
So, I have installed the kernel-default-devel as you told me but I still have the same problem.

rpm -qa | grep kernel
linux-kernel-headers-2.6.31-3.4.noarch
kernel-source-2.6.31.12-20.1.noarch
kernel-desktop-2.6.31.12-0.1.1.i586
kernel-default-devel-2.6.31.12-20.1.i586
kernel-default-2.6.31.12-0.1.1.i586

Why is my kernel-default version different from the kernel-default-devel? I believe the problem is now in this issue.

The error I get on VMware is that “Kernel heards for version 2.6.31.12-0.1-default were not found…”

Any idea? What am I doing wrong?

Thank you.

Then install the packages in matching versions.

BTW:

In the official Repos, there is no kernel-default of that version, so I don’t know where you are pulling that from, but it is certainly NOT an official repo!

Problem solved :slight_smile: Thank you for the tip.
While trying to get the most recent version of the headers, I’ve added this repository:

Index of /repositories/Kernel:/openSUSE-11.2/openSUSE_11.2

This is why I was having a different kernel_default version. After disabled it and downgrade the kernel-default-devel, all went fine.

Thank you again :slight_smile:

Hi

I have had this happen with vmware player and have a far easier solution

Simply log out as user and log in as root and then run vmware player as normal, It will pick up the changes automatically and redo the modules that it requires. When you log back in as user again it works as normal.