Linsys WUSB54G, parameters cannot be set

I am trying again to lure a friend into openSUSE 11.0. No glittering show so far :(. After having solved a bootproblem (other thread) We now are at the Wifi.

I am writing this at my own system, so things that came to my mind during writing can not be checked at this moment on my friends system, sorry for that.

The Wifi is a Linsys WUSB54G device connected via USB. We use ndiswrapper. The kernel module (ndiswrapper -…pae…) was already installed during installation, We installed ndiswrapper itself from the DVD. Copied the driver files from the XP partition and did

# ndiswrapper -i *.FIX
# ndiswrapper -l
wusb54g : driver installed
      device (5041:2234) present (alternate driver : p54usb)

Now this seems to me that ndiswrapper is doing allright until now, but here is my first question:
Does that p54usb mean that I should use that driver and not ndiswrapper? When yes, is that a product on the DVD repo?

Next step was starting YaST > Network Devices > Network Card. I first switched off IPv6 and choose traditional config with ifup. After restart YaST told me that a ndiswrapper configuration was found, but the module was not loaded, it offered to do the modprobe. Very nice, I had forgotten to do that! The card was now shown in the list of NICs. I configured the card. It will use DHCP, Managed network, it got an ESSID, and a WPA-PSK key.

Ifconfig showed it as UP, but no IP address present. iwconfig gave, among other params, managed, but ESSID=none/any and nothing to be seen about WPA.

Using** iwlist wlan0 scanning **several networks are shown, so it is not dead.
Setting ESSID with iwconfig will still give none/any.
I let **iwevent **run in one terminal and redoing the config with YaST is detected by iwevent as the setting of ESSID but not of any other params and iwconfig still shows ESSID=none/any. Setting ESSID with iwconfig does the same: detected, but gone.

Hope somebody can shed any light on this behaviour.
Thanks in advance.

the driver is already there, use that instead of ndiswrapper. see if that works


Thanks for the suggestion. The problem is that when I am at my friends system he is looking over your shoulder throwing in helpful remarks without any knowledge, I do miss some clues. It only came to my mind that p54usb might be the solution already in the system and that ndiswrapper was trying to tell me that, when I was typing the above post from my notes.

I suppose the best thing to do is deinstalling ndiswrapper and then starting YaST and filling in a the module field to use p54usb. And then testing again.

I come back tomorrow.

I suppose the best thing to do is deinstalling ndiswrapper and then starting YaST and filling in a the module field to use p54usb. And then testing again.

& don’t forget to modprobe p54usb first :wink:


You will also need the firmware for the p54usb driver. That is not on
the DVD. Which file you need will depend on your specific device. Mine
wants a file named isl3887usb_bare, which I downloaded as a file named and placed that in the correct directory with the command

sudo cp /lib/firmware/isl3887usb_bare

I would download the arm file before you disband the ndiswrapper setup
and still have Internet access.


Thanks for the remark. As you can read above the ndiswrapper setup gives us NO Internet access (even no network access) so I have to download on a different system, but that will be no problem, I have my own openSUSE and an USB stick :wink:

The problem is where I download the firmware from. On the Linksys website there is only the driver to be downloaded (the file WUSB54_dr.exe, a windows executable, do not know what to do with that one).

I know there are several versions of the WUSB54G (the Linksys website talks about versions 1, 2 and 4). As mine has no version mentioned on it I suppose it is version 1. Does anyone know if is the right one for this version?

BTW I mistyped Linksys as Linsys, I apologize to Linksys and everybody who is afronted by that.:shame:

try the compat-wireless from here Index of /repositories/home:/schmolle1980/openSUSE_11.0/i586


I have spend a few ours on the system, basicaly trying two things.

Using module p54usb.
I found the file on a Prism54 website (btw it mentioned the USB product number 2234 of my device) and copied it as lwfinger explained.
I deleted the card from YaST. Removed the driver from ndiswrapper and deinstalled ndiswrapper and its pae module. The p54usb module is loaded, even after a reboot (so the modprobe isn’t needed).
Starting YaST > Network devices > Network Cards did only show the ethetnet NIC so I tried to use Add. Choose Wireless from the menu and put p54usb in the module field. On Next it asked for the Wireless parameters. Filled in and Next. Now the card is shown in YaST as wlan0. Finished. But neither ifconfig, nor iwconfig, nor the otther iw… tools see a wlan0.

Another try with ndiswrapper.
As I found on some Fedora forum that you should remove p54usb I did an modprobe -r p54usb. I also put a blacklist p54usb in /etc/modprobe.d/blacklist. Alas after a reboot **lsmod **shows that p54usb is there again. Nevertheless I did this the modprobe -r again. installed ndiswrapper and the pae module. After ndiswrapper -i *.INF and modprobe ndiswrapper lsmod shows that p54usb is loaded again and I am back at my original problem. >:(

As a byproduct I tried to install ndisgtk from an rpm (I am not sure where I found it, it may be a 10.3 one). Though it was not installed in Kmenu > Internet > More Programs, I found the ndisgtk.desktop and started it. All looked fine until I wanted to insert the *.INF file. It hung. And after that ndiswrapper from the console also hung.

I downloaded the compat-wireless rpm that deltaflyer44 mentions to an USB stick for the next session (if I still am alowed to enter my friends home by his wife, she sees me coming and going al the time, not being very social to her). I will try to google for more info on this compat-wireless.

In the meantime I am open for any suggestions. Will be back tomorrow late at the soonest.

This may not work for you… I have a WUSB54GC

I installed SuSE 11.0 on my laptop with the wifi stick NOT installed. I am NOT using ndiswrapper.

I did this:

WUSB54GC on SuSE 11-64bit working - openSUSE Forums

I’m using rt73usb module.

I copied the download to my USB stick. I will try that one also. Thanks for the link.

It took a few days to get new courage. Then I decided to go a different way and install 10.3 instead of 11.0. After all in the HCL/Network Adapters (Wireless) - openSUSE the card has a ? for 11.0. Btw there is a comment about this card which seems to be for 9.3, but it is not completely clear to me if the whole of the comment or only the first sentence is for 9.3.

Installed 10.3 from the KDE CD. Installed the …default… and **ndiswrapper **from andrewd18 (PRMs copied on an USB-stick). The **ndisgtk **PRM could not be installed because of a dependency (apparently not on the CD). Did **ndiswrapper -i … **and modprobe ndiswrapper. **ndiswrapper -l **gives the wusb54 driver loaded, but no ‘hardware detected’.

Configuring with YaST leads to the same situation as with 11.0. wlan0 is there, iwlist wlano scanning shows some access points, but no further configs (ESSID) is shown with **iwconfig, **how often configured with YaST or iwconfig.

Does realy nobody in this forum has the WUSB54G (version 1) running?

The story goes on.

In the install from the10.3 KDE CD I missed several things like **lsusb. **This made it rather tedious to work with. My friend and I succeeded in making an ethernet connection between the system and the router (long UTP cables through the house, etc.)

Installed 10.3 anew. As found in some information in other forums I put the firmware file from Prism in /lib/modules/2.6.2*-default/kernel/drivers/firmware
with the name isl3890usb. I do not know if this did anything usefull!.

Installed ndiswrapper and ndiswrapperdefault. called ndiswrapper -i …inf.
Then connected the USB device. Now ndiswrapper -l showed something like: device (5041:2234) connected. For the first time!.

Alas, configuring with YaST did not get the parameters in the device in such a way that iwlist shows them.

Because I had read somewhere: “Then I called Network Manager and it was there”, I decided to try Netwotk Manager. Had to find out about it, never used before.
First I changed in YaST from ‘Traditional …’ to ‘Network Manager’. Then I started network Manager from Kmenu. It showed the card and I tried to use it. Did not work, but it showed the ESSID of the network to be used with a very low %. We changed the device for another one and this time… It connected! We got an IP address from the DHCP server.

We still cannot connect to any system on the LAN (including the router), but I can understand that having a connection through eth0, wlan0 and wlan1 is a bit to much. We wiill sort that out later.

My conclusion: I still do not understand what was going wrong all the time and what we did allright this time.