Linksys WUSB54GC Setup Help!

Hello All!

I’m trying to set up the above listed WLAN USB card, with little success. I just installed openSUSE 11.0 and am unsure on how to set this up. I downloaded the Linux driver for the RT73 chipset, and that’s where I’m stuck! I don’t know how to install this driver into Linux.



P4 HT, 512 MB RAM, 75 GB HDD, openSUSE 11.0 RC.

It’s generally not easy to do and I’m sure most will agree. It will probably be that you will get recommended to use a board based card and by the sound of your spec you may have a pci slot avail. A google search specific to your question may reveal how to compile the driver, but I suspect it will be fraught with problems. Sorry I can’t be any more +. Maybe someone else can be?

No, every piece of info I can get is helpful, thank you for taking the time to post! The reason that I went with this USB device is that I read on a thread on the previous suse linux forum that there weren’t any problems using this WLAN on any other opensuse release before 11.0 by the way:

BUS 001 Device 004: ID 13b1:0020 Linksys WUSB54GC 802.11g Adapter [ralink rt73]

The driver that I downloaded is here I got the third one down “RT2501USB” driver, I just don’t know what to do with it next!

not sure what others might think of using ndiswrapper but it could be done for sure. did the usb device come with an installer cd for windows with drivers on it? you could use ndiswrapper to use those drivers under linux. others may have better suggestions though.

You have to extract the archive. There may be instruction within or is the Doc info on the link you gave any use?

A quick scan of our archives revealed this Link maybe it will help


ok… I followed the instructions and everything seemed well! I decided to restart the computer, and after the restart I can’t get onto any wireless networks! Did I maybe need to do something special to enable the WLAN device on boot? That’s what I have it set for in yast. Maybe I need to use a different manager, other that Knetwork manager. Any input is appreciated!

not out just yet for suse 11 but should be soon is wifi-radar, that’s really good

OK…Maybe I should uninstall 11.0 & install 10.3, if nothing else, just because it’s “perfected.” That will be my project for the day and I’ll post again with a status update on whether or not the install for the WLAN USB worked or not! Thanks so much for the heads up about Wifi-radar, I used to have that on my laptop and completely forgot about it! However, how would I go about making Wifi-radar start at boot of the computer? Do I need to write a script for it? If so, how does one go about that?

simple way of getting it to start at boot up was to put the short cut to it in your autostart folder (by default /home/username/.Autostart

this will run it at boot, but first it will ask for your root pasword, enter it and wifi-radar will be up. hope this helps.

there may be a way to get it to run without having to enter root password each time, but i don’t know. you may find network manager works fine for you in 10.3, who knows.

anyway, post back with results,


Alright, I installed OS 10.3, followed the instructions link from Deltaflyer above, and I still can’t connect to my network. If I usa Knetworkmanager, I can see my network along with all of my neighbors’ networks, I installed wifi-radar and when I’m using Knetworkmanager, I can see all of the networks through wifi-radar, and still can’t connect. If I select ifup in Yast, I can’t see any of the networks through wifi-radar. Is there a special configuration that I missed? Needless to say, I’m a little confused.

have you set it to on-boot with ifup ?as for wifi radar you have to configure the connection you wish to connect to


Alright, I got it! I’m not really sure what I was doing wrong, I just undid & redid all of the previous steps from before, restarted, and everything worked. One question that I had is do I need to keep wifi-radar open all of the time, or can I close out of the window? Is there maybe a way to get it into the system tray?

Thanks again everyone!!

once connected you can just close wifi-radar’s window & you’ll still be connected,or just minimise it & put it in another desktop


All of the connections in wifi-radar show a 802.11 b connection. Is there something else I have to do to get them to be a G connection?

nope, that’s just a wifi-radar anomaly, i had that until i compiled wifi-radar & all was ok after that. You could let the owner/builder know & see if he can fix it. personally,it’s not that much of a hassle,so i wouldn’t worry


ok…I had all of my connections working perfectly. I decided to update my kernel, and now wifi-radar won’t start. I removed it, then downloaded the latest rpm, opened konsole in that location and typed rpm -Uvh wifi-radar*. It said everything was 100% but if I try to open wifi-radar from the kmenu, I type in my root password, and nothing!

you may have forgotten the hidden wifi-radar config files ?


as deltaflyer suggested, delete the config files, since uninstalling it does not remove these, why i don’t know, but deltaflyer probably will. once deleted, reinstall again (instead of downloading .rpm files, why not get it through the packman repository, or a 1click install? anyway, once installed again, try running it through a console and see if you get any errors.

Alright, I deleted the config file from /etc/wifi-radar. I reinstalled from the downloaded rpm from pacman (I won’t have a working internet connection until I get this resolved), tried to run wifi-radar from konsole as root and it returned:

Traceback (most recent call last):
File “usr/sbin/wifi-radar”, line 1680, in <module> set_network_device(INTERFACE)
File “usr/sbin/wifi-radar”, line 120 in set_network_device INTERFACE= wireless_devices[0]
IndexError: list index out of range