Link not start firefox

when I klick to a link in an e-Mail in thunderbird then nothing is done.
The firefox not startet with this Link - why?

with regards

system settings > Default Applications > Web Browser



Yes, but nothing is done by klicking to a Link in Thunderbird.
What is here the matter?


the solution found in “Thunderbird email links dos’nt work” in Cannot launch URL from Thunderbird 3.04b to Firefox - openSUSE Forums
with following text:

I found a fix for this until they can find a patch.

  1. Launch Thunderbird
  2. Navigate to Edit → Preferences → Advanced and click on the Config Editor button
  3. Search for the following 3 entries:


network.protocol-handler.warn-external.ftp default boolean false
network.protocol-handler.warn-external.http default boolean false
network.protocol-handler.warn-external.https default boolean false

Change them by toggling from “false” to “true” as shown below:


network.protocol-handler.warn-external.ftp user set boolean true network.protocol-handler.warn-external.http user set boolean true network.protocol-handler.warn-external.https user set boolean true

Close the Config Editor and navigate to the Thunderbird’s menu and select Tools → Add-ons and click on the Browse all Add-ons link. This will call up the ‘Launch Application’ window so that you can specify a web browser application ie. Firefox

Launch Application Window

* Next to Choose an Application click on the Choose button
* Navigate to /usr/bin/firefox
* The firefox selection will now appear highlighted in blue
* Select and click next to "Remember my choice for https links
* Click on the OK button to confirm. You will note that Firefox will now launch every time you select a hyper link or browse for add-on info from Thunderbird


I hope this helps you all.

with regards

Rummelfliege, how you found out that…? Many thanks, was getting kind’a frustrated…

regards, jehojakim

You can do this even more easily by the following steps. (For the truly lazy amongst us):

  1. Open Preferences, goto the Advanced tab and choose Config Editor.
  2. Right-Click > New > String
  4. /usr/bin/firefox

Do it again adding an “s” to the first string for https and this should sort it.