linfinite loop :dependency failed for network manager wait online


After I updated (kernel + packages) my Leap 42.3 system yesterday, I can’t login due to an infinite loop after boot. (dependency failed for network manager wait online)

How should I tackle this?
I would think that disabling the network at boot would be a way to get a login prompt and then use Yast to repair. I don’t know how to do this and haven’t had much luck in my search.
So far, I can access root with rescueCD or the Leap install CD, but I don’t know what to do then.

Last resort is reinstall, it won’t take that long, but I’m starting to get tired of doing it since I left 13.2.



I imagine you’ve done the google thing with the phrase dependency failed for network manager wait online
Like this:

Or like this (similar):

There’s one in the results that says [Solved]. That might help you (or not).
It’s here:

I haven’t read any of the results so: Luck to you

Yep, I did the google thing.

It’a almost solved, no graphical login yet.
There were a few issues.

  • The ‘dependency failed for network manager’ solved itself thanks to Yast. (I could SSH to my computer). It’s a mystery to me.
  • My old, locally built, Nvidia driver had to be updated to the latest version and rebuilt.
  • Last but not least, one of the two power supply cables to my graphic card was loose due to the cleaning I did the previous week.