Line in - Intel Sound Card Problem (82801 ICH9 Family)

I have Opensuse 11.1 32bit, with KDE 4.1, and a sound card intel 82801 (ICH9 Family).

The card seems to work fine, except that I can’t have the “line in” stream to sound directly as the sound comes in. I can for example record from “line in”, and play it back later, and it works fine, but i can’t listen to whatever is coming through the “line in” as it comes in. I already tried all the settings in the kde mixer and nothing works.

I have a satellite receiver connected to my PC, so it is important for me to be able so watch tv with sound (by the way, the video card does no have audio inputs, the sound is connected directly to the line in in the sound card)

I remember that on an previous installation of opensuse 11.1 that I had on this same computer, the mixer had an option called “loop playback” or something like that, that did the trick of activating the “line in” to sound directly on my speakers, but on this fresh copy, that option is not there anymore!

Also, when I go to yast to see the volume settings in my sound card I get this error:

YaST got signal 11 at YCP file Wizard.ycp:743
/sbin/yast2: line 440: 10468 Segmentation fault      $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

and it closes the window.

Any extra information required, please post it and I will gladly post it back.:frowning:

dare I ask if you have set up the mixer to open necessary channels?](

It is always tricky trying to help someone else with their mixer settings, when they have different hardware, as typically different hardware results in a different mixer.

I note KDE-4.1, … pardon the silly question, but have you discovered yet on KDE-4.1 that you can add extra controls/channels on your mixer via menu controls in kmix ?

Aside from that, to progress further I would need a lot of detail, and its possible I still can’t help. Still, if you are confident you have added the necessary controls to your mixer, can you then run a diagnostic script and some other command commands?

Specifically, with your PC connected to the internet, run twice in a terminal:
the first time run that with root permissions and select YES to the question do you wish to update? You need root permissions so the update to /usr/sbin directory can take place. The second time run it as a regular user, and select the SHARE/UPLOAD option. When the diagnostic script is complete, it will upload diagnostic information to the alsa web site and it will give you a URL. Please post that URL here. Just the URL.

Then please also run the following in a terminal (and post here the output):
rpm -qa ‘alsa
rpm -qa ‘pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

OK. first, I have all the channels available open. all of them!

second. here is teh link for the alsa script.

here is are the outputs for the commands requested.

cj:/home/fcj # rpm -qa '*alsa*'

fcj:/home/fcj # rpm -qa '*pulse*'

fcj:/home/fcj # rpm -q libasound2

fcj:/home/fcj # uname -a
Linux fcj #1 SMP 2009-08-15 17:53:59 +0200 i686 i686 i386 GNU/Linux

fcj:/home/fcj # cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel,snd-hda-intel
# u1Nb.PA+KAPLQWwF:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
# NXNs.UiE7Hare5X3:RV730XT Audio device [Radeon HD 4670]
alias snd-card-1 snd-hda-intel

I hope this helps!:expressionless:

OK, thanks, I note from the script output your PC has a 32-bit openSUSE-11.1 with 1.0.17/1.0.18 of alsa.

The output of the various rpm commands indicated that setup is an ok “stock” setup and has not been mistakenly altered.

I see that 4 sound devices are detected, two of which are USB devices. I assume the HDMI deivces is part of the hardware associated with the HDA-Intel (a STAC9271D).

!!Soundcards recognised by ALSA

 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xe0420000 irq 22
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xe0310000 irq 17
 2 [USX2Y          ]: USB US-X2Y - TASCAM US-X2Y
                      TASCAM US-X2Y (1604:8007 if 0 at 002/002)
 3 [camera         ]: USB-Audio - USB camera
                      USB camera at usb-0000:00:1a.1-1, full speed

For audio capture devices, I note the following:

**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
card 2: USX2Y [TASCAM US-X2Y], device 0: US-X2Y Audio [US-X2Y Audio #0]
card 3: camera [USB camera], device 0: USB Audio [USB Audio]

I assume you are trying to capture audio to the HDA-Intel Stac9271D, which has been identified as card 0.

If you are trying to capture via a “line in” input, as caf4926 suggested you need to setup the mixer to open the necessary channgels (although his image did not show it). I also believe you need to setup your mixer better. The diagnostic script output suggests it is set to NOT allow any line in, which is not what you want I believe.

Please note the following from the script output:

!!Amixer output

!!-------Mixer controls for card 0 [Intel]

Card hw:0 ‘Intel’/'HDA Intel at 0xe0420000 irq 22’
Mixer name : ‘SigmaTel STAC9271D’
Components : ‘HDA:83847627’
Simple mixer control ‘Front Mic Jack Mode’,0
Items: ‘Mic In’ ‘Line In’
Item0: 'Mic In’
Simple mixer control ‘Line Jack Mode’,0
Items: ‘Mic In’ ‘Line In’
Item0: 'Mic In’
Simple mixer control ‘Mic Jack Mode’,0
Items: ‘Mic In’ ‘Line In’
Item0: 'Mic In’
Simple mixer control ‘Capture’,0
Front Left: Capture 9 [64%] [13.50dB] [on]
Front Right: Capture 9 [64%] [13.50dB] [on]
Simple mixer control ‘Capture’,1
Front Left: Capture 0 [0%] [0.00dB] [off]
Front Right: Capture 0 [0%] [0.00dB] [off]
Simple mixer control ‘Capture’,2
Front Left: Capture 0 [0%] [0.00dB] [off]
Front Right: Capture 0 [0%] [0.00dB] [off]
Simple mixer control ‘Input Source’,0
Items: ‘Mic’ ‘Front Mic’ ‘Line’
Item0: 'Mic’
Simple mixer control ‘Input Source’,1
Items: ‘Mic’ ‘Front Mic’ ‘Line’
Item0: 'Mic’
Simple mixer control ‘Input Source’,2
Items: ‘Mic’ ‘Front Mic’ ‘Line’
Item0: 'Mic’
Simple mixer control ‘Mux’,0
Front Left: Capture 0 [0%] [0.00dB]
Front Right: Capture 0 [0%] [0.00dB]
Simple mixer control ‘Mux’,1
Front Left: Capture 0 [0%] [0.00dB]
Front Right: Capture 0 [0%] [0.00dB]
Simple mixer control ‘Mux’,2
Front Left: Capture 0 [0%] [0.00dB]
Front Right: Capture 0 [0%] [0.00dB]
I do not have your PC’s hardware, nor any experience with it, but the above does suggest a misconfiguration to me. I highlighted in RED what could be mistakes, where anyone in the wrong configuration might cause a problem.

In all cases but one, capture is set to zero to ensure NO capture. In all cases the switches are set to “Mic” and not one to “Line”. Hence Line will not function. I believe you need to set “Line” in an appropriate control and also set “capture” in the corresponding control up to a reasonably high % for capture. And you need to identify on your hardware which mixer control corresponds to what physical input.

Now mixer controls for other two are slim and I assume they are not relevant to this problem:

!!-------Mixer controls for card 2 [USX2Y]
Card hw:2 ‘USX2Y’/‘TASCAM US-X2Y (1604:8007 if 0 at 002/002)’
Controls : 0
Simple ctrls : 0

!!-------Mixer controls for card 3 [camera]
Card hw:3 ‘camera’/‘USB camera at usb-0000:00:1a.1-1, full speed’
Mixer name : ‘USB Mixer’
Components : ‘USB045e:00f5’
Simple mixer control ‘Mic’,0
Mono: Capture 0 [0%] [0.00dB] [on]
Simple mixer control ‘Auto Gain Control’,0
Mono: Playback [off]

I also searched the alsa web site for the stac9271d to see if there were any pressing updates in alsa for it, but obtained no indications of updates for the stac9271d nor stac9271. I did get a general “hit” for the stac92xx, with a couple of recent updates, but the descriptions suggest to me this may not be relevant to your PC’s stac9271D: Search results - AlsaProject

Hence for now I recommend you stick with alsa-1.0.17/1.0.18.

I have played with all the channels in order to capture the sound coming to “line in” and I have been able to do it. I know it is not a hardware problem because when I set the right configuration in the mixer I’m able to capture the sound and record it.
The problem is that the channel that loops the sound from the “line in” to the “line out” is no longer in the mixer. so even though the pc receives the sound in the “line in” I’m unable to hear it through the speakers.

Is there a way to manually add another channel to the mixer?:expressionless:

I do not have your hardware, and hence I do not have experience with your hardware.

All that I was able to see in your previous setup was you had one input set to microphone with a 64% capture (but its mixer mux setting set to zero- which may be what gives NO audio at the same time as record - I’m guessing here), and the remainder set to microphone with no capture, nor any mixer mux setting. Did you try to adjust those mux capture settings?

Were you trying to treat the line-in as a mic to get audio at the same time as record that way?

If playing with your mixer settings does not solve this, then its not likely I can solve it. You could try updating to 1.0.21 of alsa (guidance here: Alsa-update - openSUSE ) being certain to fully read that guide and to send all 6 zypper commands, and modify the 2nd zypper command to update all your alsa and not just alsa, alsa-docs and libasound2. And ensure your CD as a repository is disabled in your software package manager and ensure that OSS repos do not have a higher priority.

My view is that will not help, but I do not know this (only speculate).

In KDE4, in kmix, there is a menu item in which more mixers can be added. But only those mixers that are within that menu (and not yet selected) can be added.

Failing the above, you could try the bug report route, noting you lost a feature of this in the recent 1.0.17/1.0.18 alsa updates in 11.1. Guidance for wrtting bug reports is here: Submitting Bug Reports - openSUSE Be certain to raise this bug report against component “sound”.

Ok, first of all, thanks for the effort to help. I updated the alsa driver and still did not work, so since I remember it worked when OPENsuse was freshly installed, I decided to look what changes were made after the fresh install. I ran the OPENsuse KDE 4.1 live cd and checked the mixer, and there it was. In the channels that could be added to the mixer, there was one called “analog loopback” which has the setting to just turn it on and of. As soon as I turned it on, there it was the sound from my satellite receiver, connected to the “line in”.

So I went back to my regular kde and tried to downgrade the alsa driver to the original in the cd. I was able to do it, and the sound still works fine, but that channel “analog loopback” is not available anymore.
do you think it was something that was changed in a kernel update? that’s the only thing I can think of!

any help would be greatly appreciated!:frowning:

Unlikely the kernel.

More likely the alsa version.

Write a bug report on this, and explain what you just did.