line 31: syntax error near unexpected token `||'

Hi all, i’m trying to build gnome-appfolders-manager, but it gives me an error, and apparently it’s not something i can fix in the spec file.
I tried about a week ago to build it on fedora, and it built fine (locally), then i uploaded it on OBS and started all the mess, because on opensuse AND fedora all the dependencies were wrong, but i am now focusing on opensuse, i adjusted all the dependencies and there is still an error:


   78s] running install_egg_info
   78s] Writing /home/abuild/rpmbuild/BUILDROOT/gnome-appfolders-manager-0.3.1-20.1.x86_64/usr/lib/python2.7/site-packages/GNOME_App_Folders_Manager-0.3.1-py2.7.egg-info
   78s] /var/tmp/rpm-tmp.eWN3Qt: line 31: syntax error near unexpected token `||'
   78s] error: Bad exit status from /var/tmp/rpm-tmp.eWN3Qt (%install)

When i tried to build it locally, i could see what is there in the rpm-tmp.blahblah file, and its contents are these:


#!/bin/sh

  RPM_SOURCE_DIR="/home/pival81/rpmbuild/SOURCES"
  RPM_BUILD_DIR="/home/pival81/rpmbuild/BUILD"
  RPM_OPT_FLAGS="-O2 -g -m64 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables"
  RPM_ARCH="x86_64"
  RPM_OS="linux"
  export RPM_SOURCE_DIR RPM_BUILD_DIR RPM_OPT_FLAGS RPM_ARCH RPM_OS
  RPM_DOC_DIR="/usr/share/doc/packages"
  export RPM_DOC_DIR
  RPM_PACKAGE_NAME="gnome-appfolders-manager"
  RPM_PACKAGE_VERSION="0.3.1"
  RPM_PACKAGE_RELEASE="1"
  export RPM_PACKAGE_NAME RPM_PACKAGE_VERSION RPM_PACKAGE_RELEASE
  LANG=C
  export LANG
  unset CDPATH DISPLAY ||:
  RPM_BUILD_ROOT="/home/pival81/rpmbuild/BUILDROOT/gnome-appfolders-manager-0.3.1-1.x86_64"
  export RPM_BUILD_ROOT
  
  PKG_CONFIG_PATH="${PKG_CONFIG_PATH}:/usr/lib64/pkgconfig:/usr/share/pkgconfig"
  export PKG_CONFIG_PATH
  
  set -x
  umask 022
  cd "/home/pival81/rpmbuild/BUILD"
cd 'gnome-appfolders-manager-0.3.1'
mkdir -p /home/pival81/rpmbuild/BUILDROOT/gnome-appfolders-manager-0.3.1-1.x86_64
/usr/bin/python2 setup.py install --root /home/pival81/rpmbuild/BUILDROOT/gnome-appfolders-manager-0.3.1-1.x86_64

   /usr/lib/rpm/suse_update_desktop_file.sh -r gnome-appfolders-manager Utility;GTK; || exit 1 
  

    
    
    
    /usr/lib/rpm/brp-compress 
    /usr/lib/rpm/brp-suse  

Now i don’t know how to solve this, hope anyone can help!

You see nothing strange in this line?

i know there is || in there, but i can’t edit that file.
Also, you can see the spec file here.

You can edit spec file and put quotes around categories names.

i just did this, it still doesn’t work, saying “No sufficient category definition”.

but it works building it locally.

So your problem is fixed. If you have another problem, ask new question with suitable subject.

On Wed 22 Jun 2016 12:46:01 PM CDT, Pival81 wrote:

i just did this, it still doesn’t work, saying “No sufficient category
definition”.

Hi
Correct, one ‘Primary’ and one secondary are required, your using
primary categories, plus settings is a better fit…
https://en.opensuse.org/openSUSE:Packaging_desktop_menu_categories#Settings

So the Primary category (In the menu) is Settings, then for example
DesktopSettings as the secondary category.

See:


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.26-21-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!