libzypp Not found after update


First of all i’d like to say hello as this is my first post here. I tried tons of linux distros before i decided on openSuse as it was the first to work out of the box with all my hardware.

Anyway, to my question/problem, i just run a system update which seemed to complete correctly, however, whenever i try and run the’Install Software’ tool i’m given the following error:>not found
warning: the gtk frontend is installed but does not work
GTK GUI wanted but not found falling back to Qt.
Error while creating client module online_update_configuration

I’ve googled but can’t find anything to help with my problem.

Could somebody here please help a complete linux noob.



Welcome to our forums.

As it seems that the “systems update” was instrumental in causing your problem, could you tell what you did. “System update” is a rather vague expression I am afraid. Also, before certain people come her to ask you, an you please post the output of

zypper lr -d

I helped an IRC #suse chat user the other day who borgued their zypper by having the update of zypper fail in mid-update, such that they had no zypper and no yast software management.

We solved the problem by having the user download zypper (and its dependencies) from the “UPDATE” repos, and install zypper (and its dependencies) via rpm command (which was painful) and then fix the problem with yast by running:

zypper ve

Note that PRIOR to doing this zypper command, we ensured they ONLY had the repos: OSS, Non-OSS, Update and Packman enabled.

But we succeeded in the end.

Thanks guys, i ran the command oldcpu mentioned and it fixed the problem i was having.

Thanks again. :smiley:

Thats good news. I am glad to read this worked.

Do you mean only “Zypper” & “libzypp” ?

I mean what ever the rpm command asks for when you try to install with:
rpm -Uvh < application01.rpm > < application02.rpm > …
It will give you dependency warnings …

You may need more than just those 2 (I can not remember). When I type: rpm -qR zypper #I get:

libzypp >= 6.31.4               
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1 
rpmlib(PayloadIsLzma) <= 4.4.6-1

and when I type: rpm -qR libzypp #I get:

satsolver-tools = 0.14.17        
aria2 >= 1.1.2                   
libcurl4 >= 7.19.4               
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1 
rpmlib(PayloadIsLzma) <= 4.4.6-1

but you likely have most if not all of those already installed.

I don’t think the rabbit hole is too deep.

I’ve read at least 3 posts today about problems with Online Update and “borgued” zypper. As per the famous line from The Marathon Man: “Is it safe?” to run Online Update, or is there a confirmed problem with a package in the latest updates regarding zypper…?

I haven’t run update in a couple of days, so before I do that, I was just wondering…

For what it is worth I have no problems.

Several of the problems seem to have happened when a update did not instantly happen and the person aborted midstream

Its safe to run. Just don’t abort in the middle of the update.